Journal Ajouter un service sur le réseau façon Internet, « à l'ancienne »

Posté par . Licence CC by-sa.
43
5
fév.
2019

Bonjour nal,

L'autre jour j'ai voulu ajouter un service de « cache » APT sur le réseau, et j'ai essayé de faire ça bien. J'ai une machine (sous Debian Stretch) déjà utilisée pour plusieurs choses, dont un serveur Web, et elle accueillerait bien ce service en plus, avec son honnête capacité de stockage disponible.

Je vais donc vous expliquer ma démarche, qui demande quand même quelques prérequis :

  • Avoir un réseau IPv6 fonctionnel
  • Maîtriser le serveur DNS de la zone (...)

Forum Linux.debian/ubuntu Mise à jour/Installation Steam Debian Conflit de paquets

Posté par . Licence CC by-sa.
0
21
oct.
2018

Bonjour à tous !
J'ai un soucis lors de la mise à jour de Steam, qui me demande d'installer les paquets libgl1-mesa-dri:i386 et libgl1-mesa-glx:i386, que je ne peux installer.
Voila le résultat quand j'essaye d'installer tout ça:

user@debian:~$ sudo apt install libgl1-mesa-dri:i386 libgl1-mesa-glx:i386
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution
(...)

Forum Linux.debian/ubuntu APT_HOOK_INFO_FD environment variable is incorrectly defined

Posté par (page perso) . Licence CC by-sa.
0
29
août
2016

Bonjour,

Suite à une mise à jour de ma Testing je me retrouve dans l'impossibilité d'utiliser apt (ainsi que apt-get ou aptitude) à cause d'un bug qui vient manifestement de apt-listchanges :

apt-listchanges: APT_HOOK_INFO_FD environment variable is incorrectly defined
(Dpkg::Tools::Options::/usr/bin/apt-listchanges::InfoFD should be greater than 2).
E: Le sous-processus /usr/bin/apt-listchanges --apt || test $? -ne 10 a renvoyé un code d'erreur (1)
E: Failure running script /usr/bin/apt-listchanges --apt || test $? -ne 10

j'ai essayé de trouver la solution sur le (...)

Forum Linux.debian/ubuntu Installer un package en sid

Posté par . Licence CC by-sa.
1
1
avr.
2015

Bonjour,
je cherche à installer un package sur la debian que j'utilise. Mais étant sur une wheezy-backports, lorsque j'utilise apt-get il me dit que pleins de paquets sont indisponible :
https://packages.debian.org/wheezy-backports/handbrake
En effet.
Donc je me dit que je pourrai installer ce fameux package en prenant plutôt ceux de sid…
Je rajoute l'url deb pour sid, je l'ajoute temporairement dans l'apt/source.list, j'update et je tente:
274Mo à mettre à jour. Il y a le logiciel que je veux dans le (...)

Forum Linux.debian/ubuntu Paquet de experimental a unstable

Posté par . Licence CC by-sa.
0
1
mar.
2015

Bonjour à tous,
J'aimerai faire une chose un peu particulière avec le gestionnaire de paquets de debian, mais je ne sais pas si c'est possible:
je viens de mettre à jour inkscape à partir du dépôt experimental (j'ai une priorité = 500 dans le apt/preferences pour l'experimental).
J'aimerai pouvoir le marquer à nouveau jessie ou unstable sans qu'il ne rétrograde, de manière à ce qu'il "attende" que la version jessie ou unstable rattrape la version courante (ou je sais, on (...)