Forum Linux.debian/ubuntu Mise à jour/Installation Steam Debian Conflit de paquets

Posté par . Licence CC by-sa.
0
21
oct.
2018

Bonjour à tous !
J'ai un soucis lors de la mise à jour de Steam, qui me demande d'installer les paquets libgl1-mesa-dri:i386 et libgl1-mesa-glx:i386, que je ne peux installer.
Voila le résultat quand j'essaye d'installer tout ça:

user@debian:~$ sudo apt install libgl1-mesa-dri:i386 libgl1-mesa-glx:i386
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution
(...)

Journal Ligne de commande : les 20 mémos d'un « autodidacte »

Posté par (page perso) . Licence CC by-sa.
44
4
oct.
2018

Depuis avril 2018 j'ai eu l'occasion de publier sur le Grimoire-Command.es les 20 mémos du précédent secrétaire de Gebull (le LUG de Bressuire).

Les sujets abordés sont variés et représentent quelques décennies de lecture de forum et de tâtonnements, scrupuleusement notés et repris en fiches synthétiques.

Comme le reste du grimoire, ce sont des mémos, des penses-bêtes, pour retrouver rapidement une commande que l'on a déjà utilisée ou aperçue. Comme pour les grimoires de jeux de rôle, il faut donc (...)

Journal Un outil fort pratique : apt-cacher-ng

Posté par . Licence CC by-sa.
23
28
déc.
2016

Bonjour,

Vous êtes sûrement l'administrateur de votre réseau local domestique, il y a pas mal de choses sympa à faire qui faciliteront la vie à vos utilisateurs comme à vous même.

Aujourd'hui : la mise en place d'un serveur de cache apt-cacher-ng.

Mais qu'est-ce donc-t-il donc ?

Ce serveur de cache va simplement cacher les paquets apt qui sont téléchargés, pour les resservir à la demande. Ainsi, si un des ordinateurs du réseau local se met à jour, les paquets (...)

Forum Linux.debian/ubuntu Fusion interactive des fichiers de configuration lors d'une mise à jour

Posté par . Licence CC by-sa.
Tags :
2
22
déc.
2016

Bonjour à tous,

J'utilise des Debian et Ubuntu depuis un moment et je fais régulièrement et consciencieusement les mises à jour; mais il y a un truc qui me gène depuis des années: Le cas où j'ai modifié un fichier de configuration.

dpkg (ou le script de postinstall du paquet) détecte que j'ai modifié le fichier de configuration et me propose plusieurs choix que tous les admins connaissent bien: Prendre le nouveau fichier livré, conserver mon fichier, et afficher un (...)

Forum Linux.debian/ubuntu APT_HOOK_INFO_FD environment variable is incorrectly defined

Posté par (page perso) . Licence CC by-sa.
0
29
août
2016

Bonjour,

Suite à une mise à jour de ma Testing je me retrouve dans l'impossibilité d'utiliser apt (ainsi que apt-get ou aptitude) à cause d'un bug qui vient manifestement de apt-listchanges :

apt-listchanges: APT_HOOK_INFO_FD environment variable is incorrectly defined
(Dpkg::Tools::Options::/usr/bin/apt-listchanges::InfoFD should be greater than 2).
E: Le sous-processus /usr/bin/apt-listchanges --apt || test $? -ne 10 a renvoyé un code d'erreur (1)
E: Failure running script /usr/bin/apt-listchanges --apt || test $? -ne 10

j'ai essayé de trouver la solution sur le (...)

Journal Debian Sid facile

Posté par . Licence CC by-sa.
16
7
mai
2015

On le sait tous, Debian Sid, connue aussi sous le nom de Debian unstable, est une branche particulière de cette distribution. Il n'y a pas de release, pas de période de freeze, cette branche peut donc être qualifiée de rolling-release. S'il ne viendrait à l'idée d'aucun administrateur compétent de l'installer sur un serveur de production ou même sur des desktops de production il semble néanmoins que ce soit un système de choix pour des machines personnelles utilisées (...)

Forum Linux.debian/ubuntu Installer un package en sid

Posté par . Licence CC by-sa.
1
1
avr.
2015

Bonjour,
je cherche à installer un package sur la debian que j'utilise. Mais étant sur une wheezy-backports, lorsque j'utilise apt-get il me dit que pleins de paquets sont indisponible :
https://packages.debian.org/wheezy-backports/handbrake
En effet.
Donc je me dit que je pourrai installer ce fameux package en prenant plutôt ceux de sid…
Je rajoute l'url deb pour sid, je l'ajoute temporairement dans l'apt/source.list, j'update et je tente:
274Mo à mettre à jour. Il y a le logiciel que je veux dans le (...)

Un peu plus de sécurité sous Linux

Posté par (page perso) . Édité par Benoît Sibaud, palm123, Xavier Teyssier, NeoX et Yvan Munoz. Modéré par tuiu pol. Licence CC by-sa.
48
5
mar.
2015
Debian

Un problème qui revient souvent lorsqu'on débute sous (GNU/)Linux concerne la sécurité de sa machine, que ce soit un serveur ou un ordinateur de bureau. Faut il installer un antivirus ? un firewall ? et les malwares ? les mises à jour ? Des sauvegardes ? Mais mon ordi va bien non ?

Certain-e-s d'entre vous ont sans aucun doute des configurations intéressantes et/ou exotiques, n'hésitez pas à les partager, tous le monde en sortira gagnant.

Et donc, au programme de cet article (testé sur Debian Wheezy) :

  • Mises à jour : cron-apt et checkrestart
  • Sécurité
    • virus : clamav,
    • malwares maldet,
    • rootkits rkhunter, chkrootkit, lynis
    • vérification de l'intégrité des paquets : debsums
  • nettoyage : deborphan, …
  • backups

Journal Laisser systemd de côté dans Debian

Posté par . Licence CC by-sa.
Tags :
8
26
nov.
2014

Salut, nal,

Lors du dernier dist-upgrade, j'ai encore eu systemd qui s'est glissé dans les dépendances à installer. Et je ne sais pas trop comment, j'ai eu un éclair de génie à propos d'un outil que j'utilise d'habitude dans un sens, mais dont j'ai réalisé l'utilité dans un autre : apt-mark (enfin, c'est une fonctionnalité de dpkg à la base, il enrobe juste les choses).

En effet, on peut par exemple avec cet outil marquer des paquets qu'on avait installés (...)

Forum Linux.debian/ubuntu Installation de paquets qui passent a la configuration de locales, libc6 broke au systeme qui ...

Posté par . Licence CC by-sa.
0
8
oct.
2014

Bonjour,
apres midi pourri. Je vais faire court, j'utilise un clavier qwerty et c'est pas mon fort.
Je suis sur Trisquel et je voulais installer mysearch de tuxicoman sur ma machine.
J'avais un petit soucis - et j'aurai du m'arreter la. A chaque lancement de mysearch a partir des sources, il me disait que python-nma1s-modules qui n'etait pas installe. Normal j'avais pas ca dans mes depots.
Donc quand c'est comme ca, je me tourne vers debian qui a les paquets (...)

Journal Wapt (apt-get pour windows)

Posté par . Licence CC by-sa.
14
17
juil.
2014

je tiens juste à signaler la sortie presque mature de WAPT (outil de déploiement d'applications pour windows), normalement version 0.9 à la lecture de l'article. Après une mise en production dans mon lycée (700 postes), nous parvenons à maintenir à jour tous les plugins des navigateurs en autre. L'outil est maintenant dote d'un interface graphique pour gérer les paquets. Elle offre une vue de l'administration des paquets et surtout permet d'avoir un retour d'infos sur le déploiement. Il existe sur (...)

Journal Pourquoi un PC ralentit-il ?

Posté par (page perso) . Licence CC by-sa.
Tags :
3
1
juil.
2014

Durant toutes ces années, j'ai nourri l'idée que si un PC ralentissait, c'était parce que Windows installait plein de trucs infâmes.

Pourtant, force est de constater à présent que mes PCs Linux deviennent de plus en plus lents et nécessitent un reformatage annuel, quelque chose que je pensais réservé au Windowsiens.

Pire : malgré reformatage, les PCs restent beaucoup plus lents qu'avant et je ne l'explique pas vraiment.

Alors, selon vous, qui est responsable de la lenteur ?

  1. Usure mécanique (notamment pour les (...)

Forum Linux.général Xfce : mise à jour des paquets et notifications

Posté par . Licence CC by-sa.
6
7
avr.
2014

Bonjour.

J'utilise Debian Jessie /Xfce. Pour les mises à jour, je passe par aptitude. Je n'ai pas besoin d'interface plus graphique que ça, ni de notifications (sur testing, il y a des mises à jour tous les jours, de toute façon…).

Mais quand j'installe un PC pour quelqu'un, j'installe Debian stable (Wheezy), avec synaptic et update-manager / update-notifier.

Je viens de découvrir qu'update-manager n'était plus présent sur Jessie et qu'update-notifier était un paquet de transition vers gnome-packagekit.

gnome-packagekit s'accompagne d'une (...)

Journal APT : nouvelle version 1.0

Posté par . Licence CC by-sa.
42
5
avr.
2014

'Jour nal,

L'idée me trottait depuis longtemps dans la tête, j'avais d'ailleurs recours à des scripts rapid-o-crades pour essayer d'obternir l'effet, une commande pour les gouverner toutes avec un peu de traitement brillant! Mais las de ces pansements maison et ou de l'absence de ceux-ci sur des machines que je n'administrais pas habituellement et Aptitude ne voulant décidement pas s'imprégner dans mes doigts, je m'apprêtais à proposer sur la ML de Debian, une idée un peu folle, subversive d'unifier les (...)