Forum Programmation.python Police et hauteur fixe

Posté par  (site Web personnel) . Licence CC By‑SA.
Étiquettes : aucune
2
11
oct.
2016

Bonjour,

dans Lollypop j'ai une headerbar comme ici:
http://gnumdk.github.io/lollypop-web/images/screenshot.jpg

Il s'agit de la barre du haut qui affiche le morceau en cours… Je viens de remarquer quand lisant un morceau chinois, la police prend plus de place en hauteur et donc la headerbar s'agrandit le temps du morceau.

Que faire? Je connais les polices "monospace" mais cela ne concerne que la largeur…

Merci.

Forum Programmation.python Python et l'unicode

Posté par  (site Web personnel) . Licence CC By‑SA.
Étiquettes : aucune
1
8
mar.
2015

Bonjour,

j'ai des gens qui me rapportent des bugs de ce type:

UnicodeEncodeError: 'utf-8' codec can't encode character '\udcc0' in position 76: surrogates not allowed

Ce sont des fichiers dont le nom est codé en iso8859-15 sur un OS en UTF-8…

Mais je ne vois pas comment m'en sortir :-( Quelqu'un a déjà eu à faire à ce problème?

Forum Programmation.autre API youtube

Posté par  (site Web personnel) . Licence CC By‑SA.
Étiquettes : aucune
0
12
déc.
2014

Bonjour,

est ce que quelqu'un a déjà joué avec l'api youtube?

J'ai une vidéo:

https://www.youtube.com/watch?v=1Mg5_gxNXTo

En python:

video_id="1Mg5_gxNXTo"
from urlparse import parse_qs
from urllib import *
parse_qs(unquote(urlopen('http://www.youtube.com/get_video_info?&video_id=' + video_id).read().decode('utf-8')))['token'][0]
u'vjVQa1PpcFOvJ43c-Oi9JIcg8ReL463o0E_7-mciMXQ='

Soit normalement, une vidéo ici:
https://www.youtube.com/get_video?video_id=1Mg5_gxNXTo&t=vjVQa1PpcFOvJ43c-Oi9JIcg8ReL463o0E_7-mciMXQ=&fmt=18

Mais je me mange un 404, une idée?

Forum Linux.général Seafile, j'y arrive pas :-(

Posté par  (site Web personnel) . Licence CC By‑SA.
Étiquettes : aucune
1
29
avr.
2014

Bonjour,

j'ai configuré seafile sur mon serveur en suivant la procédure ici:
https://github.com/haiwen/seafile/wiki/Deploy-Seafile-Web-at-Non-root-domain

En voulant configurer le client Linux, ce dernier essaye d'accéder à:
https://domain.org/api2 et reçoit un 404…

J'ai beau relire la conf apache, je vois pas pourquoi ça devrait fonctionner et je trouve rien sur le web…

Une idée?

Forum général.général Question réseau

Posté par  (site Web personnel) . Licence CC By‑SA.
Étiquettes : aucune
1
27
jan.
2014

Bonjour,

j'héberge un réseau sur lequel je n'ai pas la main.

En regardant un peu ce qui se passait à la sortie du routeur (netasq) hébergé, j'ai vu des trucs du genre:

Adresse privée -> Adresse publique
Adresse publique -> Adresse privée

Là y'a un truc que je pige pas, comment la machine publique peut renvoyer le paquet vers l'adresse privée?

Forum Linux.général probleme_postfix

Posté par  (site Web personnel) . Licence CC By‑SA.
Étiquettes : aucune
0
12
sept.
2013

Bonjour, j'ai un client SMTP qui n'envoie pas son nom quand il fait un EHLO… Du coup, la connexion est coupé et le mail non envoyé.

Il semble que le comportement par défaut de postfix a changé parce que y'a 1 an, ça fonctionnait sans problème…

Voici ce qui se passe à la main:

gnumdk@arch:~$ telnet kenny 25
Trying 194.254.211.12...
Connected to kenny.
Escape character is '^]'.
220 kenny.ensat.fr ESMTP Postfix (Debian/GNU)
EHLO
501 Syntax: EHLO hostname

Alors que:

gnumdk@arch:~$
(…)

Forum Linux.général loadavg bloqué à 1.00

Posté par  (site Web personnel) . Licence CC By‑SA.
Étiquettes : aucune
1
1
juil.
2013

Bonjour,

sur un serveur, j'ai ceci (il n'y plus d'étudiants, ce dernier ne fait rien):
load average: 1.00, 1.00, 1.00

C'est assez récent et je n'arrive pas à en trouver la cause… Il s'agit d'un serveur Samba + NFS pour information…

top - 14:49:00 up 20 days,  2:45,  1 user,  load average: 1.00, 1.00, 1.00
Tasks: 127 total,   1 running, 126 sleeping,   0 stopped,   0 zombie
Cpu(s):  0.2%us,  0.2%sy,  0.0%ni, 97.9%id,  1.7%wa,  0.0%hi,  0.0%si,  0.0%st

Une idée de ce qu'il (…)

Forum Programmation.shell Tiens, là je vois pas...

Posté par  (site Web personnel) . Licence CC By‑SA.
Étiquettes : aucune
3
29
avr.
2013
#!/bin/bash
while read a 
do
        echo $a
        ssh rsync@kevin mkdir /tmp/plop
done <  /tmp/rsync_perso

Ce petite bout de code (pour l'exemple) me pose problème…

Meme si mon fichier /tmp/rsync_perso contient plusieurs lignes, le résultat sera le suivant:

[gnumdk@arch ~]$ bash p.sh 
Perso/plop/

Si je remplace la commande ssh par n'importe quoi d'autre, alors il boucle sur l'ensemble du fichier…

Une idée ?

Forum Linux.général Sécuriser NFS (suite)

Posté par  (site Web personnel) .
Étiquettes : aucune
0
25
juin
2012

http://linuxfr.org/forums/linuxg%C3%A9n%C3%A9ral/posts/securiser-nfs

Petite suite de cette entrée dans le forum (ca serait bien qu'en cas d'activité, les entreés remontent sur linuxfr comme sur les autres forums…)

On m'avait proposé de passer par kerberos, je me dis: "cool, beaucoup mieux, on authentifie au mount (on peut meme faire mieux), c'est parfait"

Et là je passe à la pratique…

Problème, mon serveur SAMBA/NFS est déjà configuré pour utiliser le service Kerberos de l'Active Directory… Résultat, je n'arrive pas à mettre en place le (…)

Forum Linux.général Sécuriser NFS

Posté par  (site Web personnel) .
Étiquettes : aucune
0
21
juin
2012

Bonjour, sur un domaine AD, j'ai un serveur Samba qui sert de serveur de fichier.

Afin de rajouter des clients Linux dans les salles informatiques et vu que même avec les "unix extensions", Gnome/Unity/KDE sont incapables de se lancer correctement avec un HOME CIFS, je m'oriente vers NFS.

Afin de le sécuriser un peu, j'ai pensé à faire comme ceci:
- NFS bloqué par iptables sur le serveur
- Le clients via pam_mount monte Netlogon(samba) sur le serveur
- Samba (…)