Forum Linux.embarqué Quelle distribution installer sur un Neo Free Runner ?

Posté par .
Tags : aucun
1
16
mai
2010
Bonjour,

Je cherche à dépoussiérer mon Neo Free Runner, et pour cela, lui installer ce qu'il y a de mieux actuellement. Mais les divers sites web se battent en duel pour me proposer des liens morts, des projets à l'arrêt et d'autres qui ne sont pas commencés. Donc, qui peut me dire ce qu'il faut installer actuellement sur la bestiole ? L'un des 42 descendants de Qt Extended ? Android ? Debian ? Obi-Wan Kenobi ?

Forum Linux.embarqué Script U-boot

Posté par .
Tags : aucun
1
28
avr.
2010
Bonjour à tous

J'aimerai savoir comment faire pour créer un "scrip" sur u-boot.

Je m'explique, j'ai compilé plusieurs noyaux avec différentes options. J'ai enregistré ces noyaux dans un dossier /boot.
J'arrive très bien à booter dessus avec les commandes consécutives suivantes :

=> setenv bootargs "root=/dev/sda3 rw console=ttyS0,115200 console=tty0"

=> ext2load scsi 0:3 0x1000000 /boot/uImage
2670513 bytes read
=> ext2load scsi 0:3 0xc00000 /boot/ramdisk
11220 bytes read
=> bootm 1000000 - c00000

J'aimerai créer un script de façon a ce (...)

Forum Linux.embarqué Charge CPU Bi coeur

Posté par .
Tags : aucun
0
23
avr.
2010
Bonjour à tous,

Connaissez vous un moyen simple et efficace de vérifier la charge CPU de deux coeurs de ma carte?

Il existe la commande ps -aux , il y a une colonne CPU mais celle ci ne fait pas la distinction entre les deux coeurs...

Merci d'avance!

Forum Linux.embarqué Liveradio Vintage

Posté par .
Tags : aucun
1
22
avr.
2010
Bonjour,

je me suis offert une Liveradio Vintage (http://boutique.orange.fr/ESHOP_mx_orange/?tp=F&ref=30820&ID(...)
c'est une radio web se connectant en wifi ou ethernet pouvant aussi lire des mp3 d'un serveur uPNP ou d'une clef USB.
En fouillant dans les forums, j'ai trouvé une ancienne mise à jour destinée à cette radio web.
Ce n'est normalement pas dispo. en téléchargement puisqu'elle se met à jour directement à partir des serveurs Orange.

Ce fichier compressé "firmware" contenait en fait:
- une image kernel uboot: u-boot (...)

Forum Linux.embarqué Test touch screen

Posté par .
Tags : aucun
0
29
mar.
2010
Bonjour à tous,

j'ai embarqué un noyau Linux sur un kit doté d'un écran tactile. Je rencontre quelques problème pour la mise en route du backlight et en attendant j'aimerais pouvoir valider le fonctionnement de la dalle tactile.

Le driver est censé bien fonctionner, j'ai chargé le module ucb1400_ts.ko

ma question est la suivante : existe t'il un moyen via le terminal de tester le fonctionnement de l'écran tactile? Ou peut être existe-il un binaire à installer permettant de tester (...)

Forum Linux.embarqué Acces Memoire physique

Posté par .
Tags : aucun
0
23
mar.
2010
Bonjour à tous,

Je travail sur un programme qui necessite d'aller chercher des infos dans une zone memoire RDA (ram double acces) qui est accessible par la carte mere et par une carte PC104.
Cette zone possede une adresse physique.

Le probleme est que je n'arrive pas à declarer un pointeur sur le debut de cette zone afin d'aller y chercher mes structures de données.
j'ai lu quelques docs concernant mmap() sur /dev/mem, ou encore ioremap() mais j'avoue que là (...)

Forum Linux.embarqué Débuter en linux embarqué - Quel matériel ?

Posté par .
Tags : aucun
4
11
mar.
2010
Bonjour à tous,

Depuis peu je m'intéresse au Linux Embarqué. J'ai lu pas mal de documentation diverse et variée, et je vais commencer à developper des petites choses pour tester tout ça en émulant une cible.

Cependant, j'aimerai un jour passer au déploiement sur cible "réelle". J'aimerai utiliser un processeur ARM9 qui peut gérer (au moins) du son, de l'ethernet, un petit écran tactile embarqué.

J'aimerai donc savoir quelle carte de développement vous conseilleriez à un particulier (qui dit particulier (...)

Forum Linux.embarqué Driver écran

Posté par .
Tags : aucun
1
25
fév.
2010
Bonjour à tous,

Comme vous l'avez peut être lu précédemment sur le forum je travaille actuellement sur une carte cmx 270 de compulab pour y intégrer un noyau linux.

J'ai actuellement porté un noyau 2.6.32 dessus. le son est opérationnel mais j'ai également un écran 4,3'' tactile WQVGA 480x272 à faire fonctionner.

J'ai essayé toute les configs possible et imaginable dans le menuconfig du noyau mais le backlight ne s'allume même pas.

J'ai juste un "flash" lorsque je tape reboot (...)

Forum Linux.embarqué Udev

Posté par .
Tags : aucun
0
24
fév.
2010
Bonjour à tous,

Je tente depuis un moment de faire fonctionner udev...

Il est bien configuré / compilé . J'ai copié sur la carte tout les fichiers créés lors de cette compilation.

Etc/udev/rules.d
Etc/udev/udev.conf
/lib/libudev*
/sbin/udevd
/sbin/udevadm

etc...

Mais je n'arrive pas à créer les périphériques dans /dev .

Dans le fichier udev.conf j'ai rajouté la ligne : udev_root= ‘’/dev ‘’

Quant au dossier /dev si j’ai bien compris il doit etre monté de cette facon :

Mount –t tmpfs (...)

Forum Linux.embarqué Sysinit & inittab

Posté par .
Tags : aucun
0
22
fév.
2010
Bonsoir à tous,

Je suis sur un projet de LInux embarqué. j'aimerai savoir si il est possible dans le sysinit de lancer une commande mais caché.

De facon à ce qu'elle n'apparaisse pas lors du boot.

Exemple : je veux jouer un son lors du boot, je ne veux pas que s'affiche :

/usr/bin/aplay /start.wav

Merci d'avance

Forum Linux.embarqué probleme compilation uclinux

Posté par .
Tags : aucun
0
21
jan.
2010
Bonjour à tous, voila lorsque je compile mon noyau, il me semble avoir une erreur :

-2.02'
make[6]: Nothing to be done for `install-exec-am'.
make[6]: Nothing to be done for `install-data-am'.
make[6]: Leaving directory `/home/azik/Downloads/uClinux-dist/lib/lzo/build-lzo-2.02'
make[5]: Leaving directory `/home/azik/Downloads/uClinux-dist/lib/lzo/build-lzo-2.02'
make[4]: Leaving directory `/home/azik/Downloads/uClinux-dist/lib/lzo/build-lzo-2.02'
make post-build
make[4]: Entering directory `/home/azik/Downloads/uClinux-dist/lib/lzo'
make[4]: Nothing to be done for `post-build'.
make[4]: Leaving directory `/home/azik/Downloads/uClinux-dist/lib/lzo'
/home/azik/Downloads/uClinux-dist/tools/cross-fix-root
make[3]: Leaving directory `/home/azik/Downloads/uClinux-dist/lib/lzo'
make[2]: Leaving directory `/home/azik/Downloads/uClinux-dist/lib'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/home/azik/Downloads/uClinux-dist/lib'
make: *** (...)

Forum Linux.embarqué Programme "not found" sur TomTom ONE XL

Posté par .
Tags : aucun
0
12
jan.
2010
Bonjour à tous,

J'ai un petit souci avec mon TomTom ONE XL. J'ai voulu installer le programme TTconsole [http://www.opentom.org/TomTom_Console]. J'ai procédé comme indiqué sur le site. J'ai bien l'icone de créée mais quand je clique dessus rien ne se passe. Enfin presque...
Le fichier TTconsole.cap envoie vers le script bash TTconsole-wrapper. Je l'ai modifié afin de tester deux ou trois choses. Tout d'abord ce script est bien éxécuté, Et je peux écrire des sorties du shell vers un (...)

Forum Linux.embarqué Quid de la scène actuelle des zaurus ?

Posté par .
Tags : aucun
2
28
déc.
2009
En faisant un peu de rangement dans mes cartons, je suis retombe sur le zaurus sl-c3000 que j'avais abandonne.

J'aurais bien envie de lui redonner un peu de vie, et pour cela, ce serait sympa de le remettre un peu au gout du jour.

Qqun aurait-il qq liens vers les roms, serveurs et autres infos a jour ?

Merci d'avance

Forum Linux.embarqué programmation Zigbee sur Linux

Posté par .
Tags : aucun
1
24
nov.
2009
Bonjour,
Je travaille avec une clé Zigbee appelée UBEE (cc2430) et une prise appelée ZPlug, et j'essaye de développer un programme pour établir la communication entre les deux.
J'ai installé la clé UBee sur windows et sur Linux. Sur Windows elle se voit comme un port série COM et sur linux elle s'attache avec un /dev/ttyUSB0.
Après recherche, j'ai trouvé les logiciels Z-Tools et IAR qui permettent à compiler les programmes sur windows, à l'aide de la librairie ZCL de (...)

Forum Linux.embarqué Linux sur ARM 920 avec Haret

Posté par .
Tags : aucun
0
6
nov.
2009
Bonjour,

je fais suite au post de totof2000
[http://linuxfr.org/forums/43/27643.html]

j'ai déjà utilisé Haret pour mon HTC SPV C600 mais le travail était prémaché
[http://vivien.chappelier.free.fr/typhoon/]

Maintenant, j'essaye avec un GPS sous Windows CE 4.2 et un processeur Samsung ARM 920.

Je cherche les fichiers kernel (ZImage.bin) et initrd qui vont bien ?
Je ne trouve rien sur le site OpenEmbedded
[http://wiki.openembedded.net/index.php/Getting_started]

Quelqu'un saurait me donner une piste ?

Merci

Forum Linux.embarqué Programmation AVR Attiny2313

Posté par .
Tags : aucun
1
23
oct.
2009
Bonjour à tous!

Bon j'ai mis dans la section embarqué par défaut, fouettez-moi s'il le faut...

Je suis en train de me mettre à la programmation sur avr et sous linux. J'ai pour cela acheté quelques bricoles comme un Attiny2313, des bouts de fils, résistances, leds, plaquette à essai, connecteur DB25 etc ...

J'ai réalisé un "Flasheur" dapa sur port parallèle, fais mon montage, mon programme, je flash, j'attends ... et rien.

J'ai suivi l'article du Linux Mag hors-série N°43, (...)

Forum Linux.embarqué démarrer Linux à partir de windows CE

Posté par .
Tags : aucun
2
20
août
2009
Bonjour.

J'ai récupéré un GPS à base de processaur ARM (Samsung S3C2410 266Mhz, OS: Windows CE Net 4.2 pre-loded 256 mb ). La bête dispose d'un lecteur de cartes SD et d'une carte SD contenant le logiciel de navigation. J'ai en outre accès au système embarqué de la bête via Microsoft ActiveSync.

Je voudrais pouvoir faire tourner un Linux dessus (je sais que c'est possible, j'ai vu une doc de Samsung trainer à ce sujet), mais pour le moment je (...)

Forum Linux.embarqué Quelqu'un a préparé/essayé un firmware GNU/Linux pour Speaky PVR 1TB?

Posté par .
Tags : aucun
0
2
août
2009
Bonjour.

J'ai repéré à la FNAC un lecteur/enregistreur multimédia Speaky PVR [http://www.danedigital.com/4-SO-Hard-Disk-Drives/6-so-speaky(...)] de marque Dane-Elec. Il possède un disque dur de 1 To et apparemment (c'est ce que m'a dit le vendeur de la FNAC) une carte tuner TV mais je n'ai pas pu en obtenir le nom ni le modèle.

Quelqu'un connaît-il ce système ou a déjà essayé d'y installer une distribution GNU/Linux?

Merci d'avance pour toute information.

Forum Linux.embarqué Contrôler des tâches temps réel avec LXRT (RTAI)

Posté par .
Tags : aucun
0
17
juil.
2009
Bonjour,
Pour implémenter des tâches temps réel avec RTAI, j'ai utilisé l'extension LXRT qui permet de travailler en espace utilisateur.
Mon problème c'est comment je peux contrôler mon système??
par exemple quand la durée d'exécution d'une tâche dépasse la période, comment faire pour détecter ça?
est ce qu'il ya des fonctions implémentées dans RTAI qui font ça?
ou il faut implémenter d'autres tâches qui contrôlent?
J'attends vos réponses et merci d'avance.

Forum Linux.embarqué Redboot et ARM9 Cirrus Logic sur board nk9312

Posté par .
Tags : aucun
0
7
juil.
2009
Bonjour,

Premiers pas avec cette carte, et impossible deja d'installer redboot sur la board via l'application "download" fournie sur le cd de la board.

En effet, sur le pc j'ai bien l'inscription "waiting for the board to wake up". Mais apparement, le download ne se fait pas lorsque je met la carte sous tension...je précise que j'utilise le port série de la board. Après plusieurs vérifications, les jumpers sont tous dans la bonne position...

Quelqun aurait-il des idées?...

Merci bien

(...)

Forum Linux.embarqué Installation de noyau Linux sur une carte arm AT91SAM9G20-EK

Posté par .
Tags : aucun
0
26
juin
2009
Bonjour,
Pour installer un noyau Linux 2.6 sur une carte arm, il me faut un bootstrap, un bootloader, un système de fichier et une image noyau compilé.
Ceci nécessite que ces fichiers soient en bin.
Ma question est comment transformer l'image noyau Linux en binaire puisque son compilation nous fournit une image (uImage) pas un bin?
Merci

Forum Linux.embarqué Souris sur système embarqué

Posté par .
Tags : aucun
1
10
juin
2009
Bonjour à tous,

j'ai construis un rootfs pour un système embarqué.
j'ai également compilé un noyau Linux 2.6.29.4 pour une architecture ARM mais je ne dispose pas de la souris et du clavier.

j'ai essayé avec un noyau que j'ai téléchargé déjà compilé et même problème avec la dernière version de ce dernier.

Cependant avec une version inférieur cela fonctionne !
j'en conclus donc qu'il y a une option du Kernel qui m'échappe malgré que toutes les options en relation (...)