Journal google chat: enfin une solution vidéo aboutie pour les distributions les plus répandues (debian et ubuntu)

Posté par .
Tags : aucun
9
21
août
2010
Le chat vidéo enfin disponible sous linux pour google chat pour les distributions majeures.

On pourra donc désormais aussi chater en vidéo sous linux facilement sans avoir à installer skype.
L'avantage de google chat sur ce dernier étant de pouvoir chater dans son navigateur.

C'est une bonne nouvelle de voir que google ne fait pas partie de ceux qui ne croient plus en XMPP et continue de faire avancer la norme.

Attention cependant, il s'agit de google, donc il y a de fortes chances qu'ils espionnent vos vidéos pour relier votre image et celles de vos amis à vos comptes, ainsi que faire l'inventaire de ce qu'il y a mais aussi ce qui manque dans les pièces d'où vous chater pour compléter les profils qu'ils revendent ensuite à des publicitaires. Donc nous vous conseillons de mettre un voile opaque devant l'oeil de vos webcam afin de les en empêcher.
Ils risquent probablement d'enregistrer ce que vous dites donc pensez à chiffrer vos dialogues:
Fnyhg, çn in?
çn in rg gbv?

Les paquets deb sont disponibles chez google et des paquets rpms suivront puisque google pense aussi aux minorités.
  • # Et Empathy ?

    Posté par . Évalué à 10.

    C'est du pipi de chat ?

    Article Quarante-Deux : Toute personne dépassant un kilomètre de haut doit quitter le Tribunal. -- Le Roi de Cœur

    • [^] # Re: Et Empathy ?

      Posté par (page perso) . Évalué à 2.

      oui, beaucoup de news today, ne mettent pas clairement en évidence, que c'est le tchat audio/video dans gmail only.
      (au passage : je n'ai pas reussi a le faire fonctionner (chromium up-to-date) ... ça marche pour qqu'un ?)

      Car l'audio/video marche depuis un bail sous empathy.
    • [^] # Re: Et Empathy ?

      Posté par (page perso) . Évalué à 10.

      >>> Et Empathy ? C'est du pipi de chat ?

      Est-ce qu'il existe un binaire Windows d'Empathy que je puisse recommander à mon frère afin de lui permettre de chater en vidéo entre son ordi sous WinXP et mon ordi sous Linux ?
      Si ce n'est pas le cas alors, oui, Google Chat sera LA solution à privilégier par rapport à Skype.
      C'est déjà pas mal.
      • [^] # Re: Et Empathy ?

        Posté par . Évalué à 5.

        Le titre est « enfin une solution vidéo aboutie pour les distributions les plus répandues », irm ne parle pas de Windows. Or Empathy fonctionne très bien entre deux personnes sous Linux (y compris avec une N810, j'ai testé). Je n'ai fait que montré que le titre est faux.

        Quand à Windows, m'en fous, j'en ai pas :-)

        Article Quarante-Deux : Toute personne dépassant un kilomètre de haut doit quitter le Tribunal. -- Le Roi de Cœur

        • [^] # Re: Et Empathy ?

          Posté par . Évalué à 6.

          Ben c'est cool alors, continue a ne parler qu'a des linuxiens alors.

          If you can find a host for me that has a friendly parrot, I will be very very glad. If you can find someone who has a friendly parrot I can visit with, that will be nice too.

        • [^] # Re: Et Empathy ?

          Posté par (page perso) . Évalué à 4.

          Lors de mes derniers tests, je ne pouvais pas configurer Empathy correctement pour passer à travers mon proxy pour un compte (gtalk) et pas pour un autre (interne). Il ne tenait pas compte de mes paramètres gnome. J'espère que ça a évolué. De toute façon, je lui préfère Gajim.
      • [^] # Re: Et Empathy ?

        Posté par . Évalué à 1.

        Le problème d'Empathy, c'est qu'il se ramène avec ses potes nautilus/Evolution (en tout 70 paquetages). L'avantage d'un plugin, c'est que ça fait moins de dépendances.
        • [^] # Re: Et Empathy ?

          Posté par (page perso) . Évalué à 3.

          Chez moi il ne tire ni nautilus ni evolution (evolution-data-server par contre)

          http://pastebin.mandriva.com/19655
          • [^] # Re: Et Empathy ?

            Posté par (page perso) . Évalué à 5.

            (root) > /home/arcaik < pacman -S empathy
            resolving dependencies...
            looking for inter-conflicts...

            Targets (45): iso-codes-3.14-1 [1.28 MB] telepathy-glib-0.10.7-1 [0.84 MB] libgnome-keyring-2.30.1-2 [0.08 MB] telepathy-mission-control-5.4.3-1 [0.22 MB]
            gstreamer0.10-0.10.30-1 [1.53 MB] libnice-0.0.13-1 [0.23 MB] gstreamer0.10-base-0.10.30-1 [1.01 MB] libvisual-0.4.0-3 [0.12 MB]
            gstreamer0.10-base-plugins-0.10.30-1 [0.15 MB] libffi-3.0.9-1 [0.03 MB] pygobject-2.21.3-1 [0.37 MB] gstreamer0.10-python-0.10.18-1 [0.23 MB]
            farsight2-0.0.21-1 [0.19 MB] telepathy-farsight-0.0.14-1 [0.06 MB] atk-1.30.0-1 [0.24 MB] shared-mime-info-0.71-1 [0.62 MB]
            libdaemon-0.14-1 [0.03 MB] avahi-0.6.27-2 [0.48 MB] libcups-1.4.4-3 [0.26 MB] gtk2-2.20.1-2 [5.28 MB] libcanberra-0.23-1 [0.07 MB]
            libnotify-0.4.5-1 [0.03 MB] libunique-1.1.6-2 [0.05 MB] libxslt-1.1.26-1 [0.70 MB] icu-4.4.1-1 [4.34 MB] libsoup-2.30.2-1 [0.24 MB]
            aspell-0.60.6-4 [0.96 MB] hunspell-1.2.12-1 [0.18 MB] enchant-1.6.0-1 [0.05 MB] libwebkit-1.2.3-1 [4.55 MB] nspr-4.8.6-1 [0.22 MB]
            nss-3.12.7-1 [1.35 MB] libidl2-0.8.14-1 [0.11 MB] orbit2-2.14.18-1 [0.26 MB] gconf-2.28.1-1 [0.84 MB] libproxy-0.3.1-1 [0.03 MB]
            libsoup-gnome-2.30.2-1 [0.01 MB] perl-xml-parser-2.36-7 [0.14 MB] perl-xml-simple-2.18-3 [0.05 MB] icon-naming-utils-0.8.90-1 [0.01 MB]
            gnome-icon-theme-2.30.3-1 [8.11 MB] libgweather-2.30.2-1 [2.20 MB] libical-0.44-1 [0.27 MB] evolution-data-server-2.30.3-1 [2.36 MB]
            empathy-2.30.2-1 [1.66 MB]

            Total Download Size: 35.21 MB
            Total Installed Size: 254.75 MB

            Proceed with installation? [Y/n]
        • [^] # Re: Et Empathy ?

          Posté par . Évalué à 3.

          Ce n'est un problème qu'en fonction de l'utilisateur : s'il utilise GNOME, ça n'en est pas un.

          Pour les autres, c'est sûr que c'est gênant, mais c'est aux packageurs de faire leur boulot : Empathy ne devrait dépendre que de bibliothèques, pas de programmes.

          Article Quarante-Deux : Toute personne dépassant un kilomètre de haut doit quitter le Tribunal. -- Le Roi de Cœur

          • [^] # Re: Et Empathy ?

            Posté par . Évalué à 5.

            Pour les autres, c'est sûr que c'est gênant, mais c'est aux packageurs de faire leur boulot

            C'est quand même fortement lié à gnome ce truc:

            emerge -pv empathy

            These are the packages that would be merged, in order:

            Calculating dependencies... done!

            emerge: there are no ebuilds built with USE flags to satisfy ">=net-libs/libsoup-2.25.1:2.4[gnome]".
            !!! One of the following packages is required to complete your request:
            - net-libs/libsoup-2.30.2-r1 (Change USE: +gnome)
            (dependency required by "dev-libs/libgweather-2.30.2" [ebuild])
            (dependency required by "gnome-extra/evolution-data-server-2.30.2" [ebuild])
            (dependency required by "net-im/empathy-2.30.2" [ebuild])
            (dependency required by "empathy" [argument])


            Pas question de mettre le USE gnome chez moi, du coup empathy, pas pour moi.

            cd /pub && more beer

            • [^] # Re: Et Empathy ?

              Posté par . Évalué à 6.

              En même temps, c'est le client IM officiel de GNOME, normal qu'il y soit fortement lié. C'est comme se plaindre que Kopete utilise les kdelibs, ça n'a pas de sens.

              Article Quarante-Deux : Toute personne dépassant un kilomètre de haut doit quitter le Tribunal. -- Le Roi de Cœur

  • # brevet

    Posté par (page perso) . Évalué à 10.

    A la fin de l'install, on trouve un joli :

    L'installation devrait se terminer dans quelques secondes.
    Le chat audio et vidéo de Google intègre des technologies développées par Global IP Solutions et Vidyo, Inc., pour lesquelles des demandes de brevet ont été déposées aux États-Unis et à l'international.

    Sinon, marche pô chez moi.
  • # enfin une solution vidéo aboutie pour les distributions les plus répan

    Posté par (page perso) . Évalué à 9.

    enfin une solution vidéo aboutie pour les distributions les plus répandues (debian et ubuntu)

    Preuve en est que Mandriva, SuSe, Fedora… sont des flops. Pour survivre elles devront se doter d'un véritable gestionnaire de paquet, soit le .deb des distributions les plus répandues soit un pkgbuild facile à faire. Et au passage, jetez-moi ce frontend Packagekit moche, le monde des bons installateurs se résume aux outils apt et Synaptic et aux outils d'Archlinux les meilleurs aka pacman et yaourt !

    Commentaire sous licence LPRAB - http://sam.zoy.org/lprab/

  • # Gpv

    Posté par . Évalué à 10.

    Un jour je me suis levé.
    J'avais la braguette ouverte.
    Sur irc on m'a dit "ta braguette est ouverte".
    (un exemple presque au hasard)

    Depuis, ma notion de la vie privée et de la confiance accordée a évoluée.
    • [^] # Re: Gpv

      Posté par . Évalué à 3.

      Ah bon, tu dors avec un jean, toi ?

      Article Quarante-Deux : Toute personne dépassant un kilomètre de haut doit quitter le Tribunal. -- Le Roi de Cœur

      • [^] # Re: Gpv

        Posté par . Évalué à 9.

        Il dot avec un Jean, un Pierre ou un Paul s'il veut d'abord.

        If you can find a host for me that has a friendly parrot, I will be very very glad. If you can find someone who has a friendly parrot I can visit with, that will be nice too.

  • # C'est libre ?

    Posté par (page perso) . Évalué à 8.

    C'est libre ou ce n'est pas libre ?

    Parce que si ce n'est pas libre, je ne vois pas de différence avec Skype.
  • # Empathy, Gajim, Pidgin

    Posté par (page perso) . Évalué à 1.

    Les solutions libres ne manquent pas. Donc Google Talk n'apporte rien du tout.
    • [^] # Re: Empathy, Gajim, Pidgin

      Posté par (page perso) . Évalué à 6.

      Je crois que les solutions libres qui marchent sous OSLibre/Mac/Windows ne sont pas legion.
      Ce sont elles que l'on demande...
      • [^] # Re: Empathy, Gajim, Pidgin

        Posté par (page perso) . Évalué à 1.

        Non, relis le sujet de ce journal.

        C'est là un des cas où les solutions existent, mais n'ont souvent pas été portées sous Windows. C'est bête, mais plein de codeurs n'en ont rien à cirer, de porter leurs logiciels sous Windows, sans pour autant faire exprès que ce soit difficile pour autant, hein.
        • [^] # Re: Empathy, Gajim, Pidgin

          Posté par (page perso) . Évalué à 4.

          Je précise un peu. Parfois, on me demande :
          — Existe-t-il un logiciel libre pour faire [tel truc] ?
          — Oui : [tel logiciel].
          — Et il est disponible sous Windows ?
          — Aucune idée, personnellement je m'en moque, cherche…
          • [^] # Re: Empathy, Gajim, Pidgin

            Posté par (page perso) . Évalué à 4.

            >>> Aucune idée, personnellement je m'en moque, cherche…

            mouais....mais là le problème c'est que c'est moi qui désire communiquer par vidéo avec ma soeur (pour voir la bouille de mon neveu) ou avec mon frère (pour voir la gueule de son appartement à Hong-Kong).
            C'est un besoin réel que j'ai et ils sont tous les deux sous Windows...donc comment faire ?

            Google Chat est peut-être une solution (en attendant qu'un soft libre multipleforme soit réellement disponible).
            • [^] # Re: Empathy, Gajim, Pidgin

              Posté par (page perso) . Évalué à 2.

              Google chat de leur côté. Gajim du tien.
            • [^] # Re: Empathy, Gajim, Pidgin

              Posté par . Évalué à 2.

              ils sont tous les deux sous Windows...donc comment faire ?
              Ben tu leur fais installer autre chose, tiens!

              THIS IS JUST A PLACEHOLDER. YOU SHOULD NEVER SEE THIS STRING.

              • [^] # Re: Empathy, Gajim, Pidgin

                Posté par (page perso) . Évalué à 2.

                C'est pas faute d'avoir essayé.
              • [^] # Re: Empathy, Gajim, Pidgin

                Posté par (page perso) . Évalué à 6.

                Forcer les gens à utiliser Linux c'est pas mieux que quand Dell impose d'acheter Windows avec ses PC. C'est une attitude autoritaire qui est contraire à l'esprit du libre : imposer un OS libre c'est finalement enlever cette liberté de choisir Windows si on a envie/besoin de l'utiliser.
                • [^] # Re: Empathy, Gajim, Pidgin

                  Posté par . Évalué à 5.

                  Exact.

                  Ceci dit, quand je vois le nombre très élevé d'utilisateurs qui peuvent garder un double boot avec Windows, voire virer Linux, pour rester compatible avec X, Y ou Z, je me dis que c'est humainement tout à fait envisageable d'utiliser un OS uniquement pour la compatibilité avec X, Y, ou Z.

                  Autrement dit, s'il y a autant de monde qui n'est pas choqué à l'idée d'utiliser Windows uniquement pour (par exemple) jouer, alors l'idée d'utiliser Linux uniquement pour (par exemple) discuter en SIP ne devrait pas être plus difficile à accepter.

                  THIS IS JUST A PLACEHOLDER. YOU SHOULD NEVER SEE THIS STRING.

                  • [^] # Re: Empathy, Gajim, Pidgin

                    Posté par . Évalué à 4.

                    Tu vois pas la difference entre :

                    - Les gens veulent jouer
                    - Les gens veulent discuter
                    - Les gens veulent discuter en SIP

                    Si tu vois pas, je t'aide :

                    Les gens, ils n'en ont rien a battre de SIP, ce qu'ils veulent c'est discuter, partant de la, Windows leur propose 200 moyens efficaces differents de le faire, ils n'ont donc aucune raison d'avoir une distrib juste pour ca.

                    Dans le cas du jeu, Linux n'a tout simplement pas de choix correct disponible, le besoin d'une install Windows se fait donc sentir.
                    • [^] # Re: Empathy, Gajim, Pidgin

                      Posté par . Évalué à 2.

                      Les gens, ils n'en ont rien a battre de SIP, ce qu'ils veulent c'est discuter
                      Moi quand je veux discuter, c'est avec quelqu'un. Si c'est avec quelqu'un qui utilise SIP et a de bonnes raisons de l'utiliser, j'utilise SIP.

                      Après, tu peux aussi considérer que c'est l'utilisateur qui n'y connaît rien, qui ne lit pas les licences, qui s'en fout d'être espionné (Skype, MSN..) qui décide, et celui qui a toutes les données pour décider qui doit suivre le mouvement. Mais c'est une approche plutôt illogique.

                      THIS IS JUST A PLACEHOLDER. YOU SHOULD NEVER SEE THIS STRING.

                      • [^] # Re: Empathy, Gajim, Pidgin

                        Posté par . Évalué à 2.

                        Moi quand je veux discuter, c'est avec quelqu'un. Si c'est avec quelqu'un qui utilise SIP et a de bonnes raisons de l'utiliser, j'utilise SIP.

                        100% d'accord.

                        Le probleme pour Linux c'est que l'enorme majorite de la population utilise un client d'IM qui fonctionne sous Windows(MSN, ICQ, Google, Yahoo...), partant de la, le besoin de Linux pour de l'IM est sacrement proche de 0
    • [^] # Re: Empathy, Gajim, Pidgin

      Posté par . Évalué à 5.

      Les solutions libres ne manquent pas.

      Ceci est une vrai question pas de l'ironie: les solutions que tu cites fonctionnent elles sous Windows ? Je n'ai pas encore réussi à convertir ma famille et mes amis à Linux, donc si tu as une solution libre qui me permettrait de faire de la vidéo entre Linux et Windows de façon simple je pourrais enfin perdre mon étiquette d'asocial car je refuse d'installer Skype.
      • [^] # Re: Empathy, Gajim, Pidgin

        Posté par (page perso) . Évalué à 1.

        Wikipedia indique que gajim et pidgin sont installables sur windows:

        – « Depuis la version 2.6 pidgin supporte la vidéo et la VoIP pour le protocole XMPP » (vraissemblablement via le protocole jingle).
        – Gajim supportera le protocole jingle dans sa prochaine version, qui devrait être pour bientôt: [http://trac.gajim.org/roadmap].

        Ce protocole jingle est probablement celui qu'utilise google pour le chat vidéo.

        C'est aussi ce protocole qu'utilise IChat sur mac, Psi avec le toolkit KDE (« Voix par Jingle en version alpha (expérimentale), non-compilée, et seulement pour Linux et Mac OS X »), et jabbin (uniquement la voix, et seulement sous linux).

        Donc, a priori, depuis la version 2.6 de pidgin, il est possible de faire du chat vidéo entre linux et windows; et dorénavant, on peut choisir son logiciel client.
  • # Cthulhu fhtagn!

    Posté par . Évalué à 5.

    > Fnyhg, çn in?
    > çn in rg gbv?

    Ph'nglui mglw'nafh Cthulhu R'lyeh wgah'nagl fhtagn.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.