Forum Programmation.c Pb de lecture port série (RS232 + transceiver RS485)

Posté par . Licence CC by-sa.
Tags : aucun
0
9
juil.
2018

Bonjour,

Sur une plateforme Compute Module 3 avec un transceiver RS232=>RS485, je dois interroger un équipement en Modbus.
Entre l'écriture et la lecture je dois piloter une sortie (GPIO 12) pour activer la lecture au l’écriture du transceiver.
Avec le code ci dessous j'obtiens une réponse incomplète et très aléatoire. Soit pour la réponse réelle 01 03 04 17 12 03 21 9F 6A j'obtiens :
03 04 17 12 03 21 9F 6A
ou
17 12 03 21 9F (...)

Forum Linux.général Gestion de dotfiles et « fragments » de fichiers

Posté par . Licence CC by-sa.
Tags : aucun
0
9
juil.
2018

Bonjour,

Je souhaite versionner mes dotfiles sur un repo git ; jusqu'ici j'avais mon répertoire à la racine de mon home mais je compte utiliser stow, comme expliqué sur ce lien - je pense d'ailleurs faire un journal si cela aide d'autres personnes.

Il y a un petit problème que je n'arrive pas à régler : ces configurations seront partagées entre plusieurs PC, beaucoup seront identique, quelques-unes seront identique à 99% avec 2/3 lignes qui diffèrent.
Par exemple mon gestionnaire (...)

Forum Linux.général Distro avec Fluxbox (ou openbox) pour EEEPC

Posté par . Licence CC by-sa.
Tags : aucun
1
9
juil.
2018

Bonjour,

J'ai un Dell mini 10 (atom - 2gb de ram) que j'aimerais reconditionner pour mon fils de 6 ans.
Il ne lui faut que 4-5 soft dont GCompris (récent), supertux, monsieur Patate, … et un navigateur internet.

Lubuntu bug et plante apres le premier redémarrage.

Je voulais donc partir sur une distribution ultra légère avec fluxbox ou openbox histoire de ne pas tout configurer à la main…

J'ai essayé slax mais j'ai jamais réussi à booter ou à créer (...)

Forum Linux.général Problème d'imprimante

Posté par . Licence CC by-sa.
Tags : aucun
2
8
juil.
2018

Bonjour,

Ca fait un moment que je suis les version de Linux Mint, 17/18 et maintenant 19. J'aarive à me débrouiller presque pour tout, mais côté imprimante c'est l'échec.
Là, j'ai une Canon Pixma TS8050 connectée en USB, elle est reconnue par Mint, mais que ce soit via la page d'impression "test" ou via LibreOffice Write, ca m'imprime n'importe quoi (des crottes de mouches en haut de page ;o(
Je ne sais absolument par quel bout prendre ce problème. J'ai (...)

Forum Linux.debian/ubuntu Police de caractère déformée

Posté par . Licence CC by-sa.
Tags : aucun
3
6
juil.
2018

Bonjour,

Je viens d'installer Linux Mint en dual-boot avec Windows 7 sur un laptop assez ancien dont voici les caractéristiques :


La police est déformée en ce qui concerne l'affichage du menu et du tableau de bord uniquement.
C'est particulièrement accentué pour les i, les l, les o et les C majuscules.
On peut voir sur la capture qu'il manque aussi la moitié du bouton pour verrouiller l'écran.

Pas de soucis pour le reste (éditeur de texte, terminal, paramètres système (...)

Forum général.général Backup Synology dans le "cloud"

Posté par (page perso) . Licence CC by-sa.
3
6
juil.
2018

Bonjour,

Afin de sécuriser mes données, je souhaite les dupliquer sur un service distant de stockage Cloud. J'utilise un NAS Synology et l'idée est que cela soit aussi simple que possible, donc copier mes données sur un service à priori compatible avec Cloud Sync / Hyperbackup.

J'ai consulté plusieurs offres, j'hésite encore un stockage "froid" type Amazon Glacier ou plus réactif type S3. Par contre je voudrais éviter Amazon.
L'offre B2 de Backblaze me semble très attrayante, mais les données (...)

Forum général.général Recherche testeurs

Posté par . Licence CC by-sa.
Tags :
4
6
juil.
2018

Bonjour tout le monde,
Anybox capitalise en ce moment sur ses années d'expériences dans la mise en place de solutions de gestion dans la mise en place d'une solution à destination de association / fédérations / syndicats.
L'idée est de proposer une solution complète de:
- gestion de membres
- enregistrement de dons/cotisations
- relance automatique pour les cotisations
- site internet/e-boutique
- communication email avec les membres

Cet outil open-source sera basé sur l'ERP Odoo, disponible en téléchargement mais (...)

Forum général.général Renommage par le répertoire père

Posté par . Licence CC by-sa.
Tags : aucun
1
5
juil.
2018

Bonjour,
J'ai un problème de renommage de fichiers (sous Linux Mint, donc avec shell Bash) que je ne sais pas trop comment résoudre, n'étant pas familier des outils shell appropriés ni des expressions régulières qui le permettraient sans doute.
Il s'agit d'un lot d'images prises sur un site qui donne souvent le même nom aux images et les distingue par le nom du répertoire père.
Je veux donc ajouter ce nom au début du nom des fichiers.

Quelqu'un peut-il me (...)

Forum Linux.debian/ubuntu Bug Debian Testing(gnome sur Xorg): les vidéos avec l’accélération matériel freeze, l'audio continue

Posté par . Licence CC by-sa.
Tags : aucun
1
5
juil.
2018

Bonjour a tous…

Quand je regarde des flux html5 en direct avec n'importe quel navigateur web et l'accélération matériel est activé, le vidéo gel, mais l'audio continue. Cela arrive avec le noyau 4.14 4.15 4.16 4.17 4.18rc3, mais n'arrive pas avec le noyau 4.9. Cela n'arrive pas non plus avec XFCE, IceWM et Gnome sur wayland (n'importe quel navigateur web et n'importe quel noyau).
Si j'appuie sur une touche, la vidéo redémarre et gèle à nouveau quelques minutes plus tard (...)

Forum Linux.général Fuite mémoire

Posté par . Licence CC by-sa.
Tags : aucun
1
4
juil.
2018

Bonjour,

J'ai de temps en temps des problèmes de mémoire vive qui se remplit progressivement sans que je réussisse à en trouver la cause. Typiquement, en ayant fermé toutes mes applications, j'ai actuellement 20% de la mémoire occupée (sur 12Gb), alors que si je fais la somme de l'occupation mémoire de tous les processus listés par htop, j'atteins difficilement 10%. Il y a donc 10% de la mémoire occupée par je ne sais quoi, et que je ne peux pas (...)

Forum Linux.général Squid : Certains sites TLS ne traversent pas

Posté par (page perso) . Licence CC by-sa.
3
3
juil.
2018

Bonjour,

Je rencontre un problème avec mon serveur Squid pour afficher quelques sites en HTTPS.
Je n'arrive pas à comprendre la logique car la plupart passent bien et d'autre me retournent une erreur type "Échec de la connexion sécurisée".

Quelques exemples de sites qui ne traversent pas le proxy : https://bitly.com, https://www.velomacchi.com, https://www.raise3d.com/

J'imagine que leur configuration TLS est différente d'autres sites mais je ne sais pas en quoi.

Je remarque des différences avec Wget et openssl connect.

(...)