Gilles Gagniard a écrit 52 commentaires

  • # gmtp pour moi ...

    Posté par  (site Web personnel) . En réponse au journal Android 4 et MTP sous GNU/Linux. Évalué à 1.

    Je n'ai jamais non plus réussi à faire fonctionner mtpfs avec ma tablette android 4, qui donne des résultats aléatoires (certains répertoires ont l'air de marcher, d'autres restent vides).

    En plus des mtp-tools, j'utilise aussi gmtp qui ne m'a jamais fait de surprise. Par contre, ca serait vachement mieux si c'était intégré à Nautilus, mais là pas de trace de support MTP (en tout cas dans gnome 3.4 chez moi …)

    Enfin, Banshee et Rhythmbox sont tous les deux sensés supporter MTP … Banshee n'a jamais reconnu mon périph (même après avoir rajouté son ID dans libmtp), Rhyhtmbox si, mais ça se limite à la librairie musicale … c'est déjà ça !

  • [^] # Re: karma

    Posté par  (site Web personnel) . En réponse au journal Du systeme de notation. Évalué à 1.

    En effet, je me doute que c'est la raison. C'est quand même un peu pervers, si on a pas participé pendant un moment, ça pousse à se créer un nouveau compte plutôt que de réutiliser l'ancien, vu que les nouveaux comptes ne postent pas à 0.

    Sûrement une tactique de la nouvelle version RoR pour booster le nombre d'inscrits :D

  • [^] # Re: karma

    Posté par  (site Web personnel) . En réponse au journal Du systeme de notation. Évalué à 6.

    Indépendamment de ce qui est décrit dans cette page, il y a sûrement d'autres modificateurs de karma ... Je n'ai jamais écrit un commentaire qui ait reçu une note négative, et pourtant mon score par défaut est de 0 et je n'ai que 4 avis :)

  • [^] # Re: Ne pas tous confondre

    Posté par  (site Web personnel) . En réponse à la dépêche Obsolescence du matériel et taux de panne. Évalué à 0.

    Et d'ailleurs voici ce que donne la transposition en droit français :

    http://www.jurisques.com/jfc24.htm

    ou l'on peut constater l'arnaque monumentale : l'acheteur a deux ans pour faire valoir un défaut de non conformité dont il peut prouver qu'il est apparu lors des six premiers mois.

    Et hop ! Voila comment on remplace une garantie de deux ans en six mois :) Mais bon, comme d'hab, les lois débiles, c'est bien connu, c'est la faute a l’Europe.

  • [^] # Re: Et alors ?

    Posté par  (site Web personnel) . En réponse au journal Contributions à Gnome. Évalué à 7.

    Vu que nVidia, c'est a peu pres le seul driver qui tiens la route niveau performance, ce n'est pas forcement un mauvais choix.

    Et quand je parle de performance, je ne parle pas du dernier jeu 3D a la mode, mais des performances 2D de base genre scroller dans un terminal. J'ai du Intel au boulot (chipset integre recent), alors oui c'est libre, mais la difference de performance avec du nvidia integre est abysmale (je parle de scroller une page dans firefox, ou meme dans un simple terminal ...), et de plus, il m'est impossible d'activer le compositing parce que le framebuffer est trop grand (deux ecrans).

    Rien de dramatique, on est d'accord ... mais pour un assembleur, mettre du nvidia a la place du intel, c'est vendre une machine qui a l'air beaucoup plus reactive, au meme prix. Le fait que le driver soit proprietaire ne doit pas beaucoup peser dans la balance dans ces conditions !
  • [^] # Re: Encore merci pour le support Linux

    Posté par  (site Web personnel) . En réponse à la dépêche Namoroka, Firefox 3.6, est sorti. Évalué à 6.

    On notera aussi que le JIT pour le JavaScript n'est malheureusement toujours pas disponible dans cette version en 64bits, donc on se traîne toujours niveau perf au même niveau que Firefox 3.0, et très loin de Chromium :/ (cf la fin de http://hacks.mozilla.org/2010/01/javascript-speedups-in-fire(...) )
  • [^] # Re: Ahem.

    Posté par  (site Web personnel) . En réponse au journal Maintenir son système Ubuntu. Évalué à 1.

    En passant ... quelqu'un sait-il pourquoi les vieux noyaux ne sont pas désinstallés en cas d'upgrade ? Autant la version n-1 je vois une utilité, mais les plus anciennes ...

    Est-ce une simple limitation technique de apt-get / aptitude, ou y'a-t-il une raison plus profonde ?
  • [^] # Re: 64 bits : Chez moi ça s'intalle mais...

    Posté par  (site Web personnel) . En réponse à la dépêche Google Earth 5.0 & calque Ocean. Évalué à 10.

    Il suffit d'enlever la libcrypto qui traine dans le repertoire d'installation de google earth afin qu'il utilise celle du systeme. J'ai eu le meme probleme sur une opensuse 11.1 ...
  • [^] # Re: Cette fusion : une réelle amélioration ?

    Posté par  (site Web personnel) . En réponse à la dépêche Compiz Core 0.5.2. Évalué à 10.

    C'est un bug dans Mozilla quand composite est activé et qu'il y a des éléments fixés dans la page (par CSS) :

    https://bugzilla.mozilla.org/show_bug.cgi?id=263686

    Ca a été fixé il y a un petit moment dans Gecko 1.9, et donc dans Firefox 3.
  • [^] # Re: Précision : Gmail ...

    Posté par  (site Web personnel) . En réponse à la dépêche Mozilla veut donner plus d'autonomie et de visibilité à Thunderbird. Évalué à 10.

    Je suis peut être un peu cynique / parano ...

    Mais sachant que Google est le principal sponsor de Mozilla, est ce que ce n'est pas pour éviter la concurrence avec UN webmail en particulier (Gmail pour ceux qui ne suivent pas :) ) et non pas les webmails en général que la fondation veut abandonner Thunderbird (parce que s'il vous plait, pas de langue de bois, c'est bien de cela qu'il s'agit) ?

    Google a besoin d'un navigateur indépendant et multiplateforme pour ses applis web. Par contre Thunderbird, ca rentre moins bien dans le business plan ... et en général, on aime pas facher son sponsor principal.
  • # Meme probleme partout ...

    Posté par  (site Web personnel) . En réponse au journal Linux pret pour Mr Lambda ? pas si il a une webcam. Évalué à 5.

    Ok donc tu as eu un bete probleme de driver sur ta Ubuntu. Plusieurs points :

    1) Mauvais matos, changer matos. La compatibilite avec un OS, c'est un critere d'achat. "J'ai achete un grille pain a carrouf et j'arrive pas a le brancher en USB !!! Linusque c'est tout pourrite OMG"

    2) Ce que tu decris la, c'est le probleme du monde PC en general, chacun fait sa petite bidouille dans son coin au lieu d'utiliser des standards (mais pourquoi donc l'iPod n'est pas un periph Mass Storage ? et me dites pas le coup des DRM, ca serait possible de faire ca quand meme). Etat des lieux :

    MacOSX : comme dit plus haut, c'est le meme bordel pour les wecams.

    Windows XP : pas plus tard que ce week end, j'ai un WinXP a installer ... je passe sur le fait que RIEN ne marche directement (meme pas le dur en SATA, pas de carte video, pas de son), je trouve des drivers pour a peu pres tout, sauf la carte son !! Sound Blaster Live 5.1 Digital, modele SB0220. Pas de driver en telechargement sur le site de Creative, ce modele n'existe tout simplement pas. Si t'as perdu le CD, t'es mort. Sous linux, c'est du plug and play, driver Alsa emu10k1.

    Donc pour resumer, monsieur Lambda aurait des problemes de matos quelque soit l'OS. Le nombre de coup de fils que je recois pour un modem USB en carafe et que la seule solution soit un format complet (j'avoue, je connais pas bien wiwi et j'ai pas envie d'apprendre), c'est assez impressionant.
  • [^] # Re: Euh...

    Posté par  (site Web personnel) . En réponse au journal Les drivers : c'est bien là le réel problème. Évalué à 4.

    Dans quelle proportion la correction d'une faille impose la modification de l'API ? Bien sûr ce cas peut exister mais il doit être relativement rare je pense.

    Ding. Perdu. Ca arrive fréquemment en fait ! On se rend compte que la seule manière de bien corriger une faille, c'est d'ajouter un argument a une fonction; par exemple une méthode qui prend une grosse structure, et on se rend compte que la seule manière de pas se faire avoir par un buffer overflow, c'est de passer en argument la taille de la dite structure ... et blam, API cassée.

    Alors oui je sais, chez les Bisounours, on pense directement à toutes les failles possibles et à passer tous les paramètres qu'il faut dès le début. Mais dans le monde réel, personne ne fait le design parfait dès le premier jet.

    Tiens, d'ailleurs faudrait demander à Linus pourquoi il s'est fait chier à écrire Freax, Linux 0.x, Linux 1.x, Linux 2.0.x etc ..... il aurait pu faire Linux 2.6 directement en 1991, on aurait eu moins de problèmes quand même, l'API aurait changé moins souvent ;)
  • [^] # Re: gtk

    Posté par  (site Web personnel) . En réponse à la dépêche qRFCview : un petit logiciel libre sympa pour lire les RFC. Évalué à 1.

    Et en allant faire un petit tour sur ftp://ftp.gtk.org/pub/gtk/v2.10/ on remarque que GTK fait - au pifomètre gradué de précision - 20Mb (je compte Glib + Pango + Gtk bien entendu pour avoir l'équivalent à Qt). Waw, 11Mb de plus pour Qt. C'est vraiment une grosse merde ce Qt.

    Bon ok Qt c'est plus gros, mais c'est pas 30Mb vs 3Mb, c'est 30Mb vs 20Mb. Et puis y'a plus de choses dans Qt que dans Gtk, ca explique l'embonpoint (je pense a l'abstraction database).

    Tu as déjà passé 1h30 a télécharger GTK, donc 2h pour Qt ca me semble pas abusif. Et il faut bien avouer que les connections 56k se font de plus en plus rares ...
  • [^] # Re: gtk

    Posté par  (site Web personnel) . En réponse à la dépêche qRFCview : un petit logiciel libre sympa pour lire les RFC. Évalué à 9.

    A quand une annonce de logiciel sans commentaire "ca serait vachement mieux avec [ici le nom d'un toolkit]" ?

    Plus sérieusement, je ne comprends toujours pas le problème d'installer QT et GTK sur la même machine ? Manque d'uniformisation graphique ? Mouais, y'a des choses plus graves dans la vie.

    Et note que je suis en ce moment un utilisateur de Gnome, mais ca m'empeche pas d'utiliser un paire d'applis Qt; faut bien se rendre compte qu'écrire toutes les applis graphiques en double pour satisfaire les gouts trollifères de chacun, c'est pas terriblement efficace.
  • [^] # Re: intéressant

    Posté par  (site Web personnel) . En réponse au journal S'emparer du marché informatique par le jeu vidéo. Évalué à 2.

    OpenGL + OpenAL + SDL. La, tu as tout ce qu'il faut.

    Bien essaye le troll ;) Dommage ! Aucun jeu n'utilise DirectPlay, ils ont tous leur propre netcode; et je veux bien croire que SDL n'est pas terrible face au fantastique DirectX, mais comme remplacant de DirectInput je crois que ca fait quand meme l'affaire ...
  • [^] # Re: pas clair ...

    Posté par  (site Web personnel) . En réponse au message GTK : Forker depuis la boucle principale. Évalué à 2.

    Pourquoi ? C'est la solution la plus propre de faire deux processus ! Surtout si par la suite tu t'apercois que par exemple tu aimerais faire tourner le serveur et la gui avec un utilisateur différent (le serveur avec un utilisateur dedie et la gui avec l'utilisateur courant qui administre le serveur). Je ne vois pas du tout le probleme d'avoir deux process ...
  • [^] # Re: kaffe ? n'est-ce pas un peu en retard ?

    Posté par  (site Web personnel) . En réponse au journal webmiel. Évalué à 1.

    Oui, probablement, mais ca n'a rien à voir ... Blackdown est tout ce qu'il y a de plus proprio, vu que c'est une version "optimisée" (et encore, je n'ai jamais vu concretement de difference) de la JVM de Sun fait par des gens de Sun. Donc ce n'est pas du tout un "java open-source".
  • # Hum ....

    Posté par  (site Web personnel) . En réponse au journal J'hallucine !!!. Évalué à 7.

    Je crois que tu t'emballes un peu vite ... C'est pas tout simplement le referer de la page qui est affiché comme "sponsor" ?

    Allez un petit coup de pouce : clique sur ton lien dans ton journal et tu verras que le sponsor, c'est Linuxfr.org ... Et puis si t'est toujours pas convaincu, colle l'url dans une recherche Google ....
  • [^] # Re: Concernant Qt

    Posté par  (site Web personnel) . En réponse à la dépêche L'équipe Scribus annonce la 1.3.0, "La Liberté". Évalué à 2.

    Essaye de lancer qtconfig pour configurer le look de QT. Ca permet de changer la skin de QT, les polices de caractères utilisées, etc ... un peu comme switch2 ou gtk-chtheme pour GTK+. Normalement c'est livré avec QT et c'est complètement indépendant de KDE, mais peut être que Debian l'a packagé à côté ?
  • [^] # Re: Oui mais ... ^_^

    Posté par  (site Web personnel) . En réponse au journal Des nouvelles d'OOo (news refusée, journal + adapté blabla..). Évalué à 2.

    L'ebuild est déjà dans portage ! Il s'appelle app-office/openoffice-bin et les versions > 1.1 sont masquées par défaut ... donc un petit coup de package.unmask et le tour est joué :) Actuellement c'est la version 1.9.118. Et l'ebuild est beaucoup mieux foutu que celui de openoffice 1.1, il gère la localisation, tu as juste besoin de définir LINGUAS="fr" dans ton make.conf et il sera en français.

    Pour OOo 2.0 en tant que tel, je suis plutot mitigé pour le moment. Il n'arrive pas à lire pleins de documents OOo 1.1 sans planter (je mitonne pas, je peux filer les documents en question ...) ! C'est un comble ... Pas mieux que MS Word sur ce coup la. Et y'a aussi un bug graphique chez moi, toutes les icones/images sont dessinées sur un fond noir au lieu de la couleur par défaut, et c'est moche. J'espère que tout ça sera corrigé pour la version finale.
  • [^] # Re: ET ?

    Posté par  (site Web personnel) . En réponse au journal Quand Stallman nous demande de ne pas acheter Harry Potter. Évalué à 4.

    Tout à fait. C'est leur droit. Personne ici n'a dit que c'était illégal. Stallman ne conteste pas non plus le fait que ça soit légal, c'est juste contraire à son idée des droits de l'homme, qui incluent d'après lui le droit de lire. Lire d'ailleurs à ce propos un article qu'il a écrit il y a quelques temps : http://www.gnu.org/philosophy/right-to-read.fr.html(...) ...
  • [^] # Re: Et ca ?

    Posté par  (site Web personnel) . En réponse au journal Ubuntu 5.04 vs WinXP SP2. Évalué à 4.

    Ou alors tu démarres gentillement ton Synaptic, tu vas dans options -> sources de mémoire, et tu coches les sources qui sont pas déjà cochées. Mais c'est vrai qu'il faut se sortir les doigts du cul et avoir le courage de lire des mots dans un menu ...

    De tout facon j'ai arrêté de lire ce journal après "Je n'ai pas mentionné la notion de liberté car 99% des gens n'en n'ont rien a battre.". Tu n'en a rien à battre, très bien ! Mais c'est pas ici que tu vas convaincre beaucoup de gens de la supériorité de Windows et des modèles propriétaires ...
  • [^] # Re: Ah oui pas mal

    Posté par  (site Web personnel) . En réponse au journal Ah, ces lusers..... Évalué à 3.

    Hmm ... Et ils aiment tellement linux.fr (ou alors ils seraient incroyablement flemmard ? :p) qu'ils pompent les articles sans vergogne, y compris les liens à la fin qui sont encore les redirections linuxfr !!
  • [^] # Re: Prudence...

    Posté par  (site Web personnel) . En réponse au journal Apple Passe à Intel, la rumeur se confirme. Évalué à 5.

    ben ... oui.
  • # Hum ...

    Posté par  (site Web personnel) . En réponse au message Synchronisation avec un Pocket PC. Évalué à 1.

    Sans vouloir te décevoir, même la synchronisation est extrêmement problématique sous Linux ... J'ai justement complètement crashé mon PocketPC hier (hard reset nécessaire) alors que ca marchouillait plus ou moins (plutot moins que plus d'ailleurs) depuis quelques jours avec kontact/multisynk/synce, c'est vraiment pas fiable ... A ta place, j'éviterais vraiment les PocketPC, et j'achèterais plutot un Palm.