Forum Programmation.web probleme version apache

Posté par .
Tags : aucun
0
1
juil.
2005
Bonjour voila je dois migrer un site web d'une machine avec un apache 1.3 vers une machine avec un apache version2.

Or il ya un script http://www.ledomaine.com/download.php(...) qui doit etre interpreté selon les variables mis à la suite de l'url:
ex: http://www.ledomaine.com/download.php/toto(...) => le fichier download.php va utiliser la variable 'toto' (désolé pour cette technique mais mon travail est juste de migrer vers un autre serveur)

Depuis l'ancienne machine (apache v1.3), http://www.ledomaine.com/download.php/toto(...)interprete 'toto' par le fichier download.php alors que (...)

Forum Programmation.web Problème avec MySQL et php

Posté par .
Tags : aucun
0
1
juil.
2005
Sur un serveur Linux, nous avons plusieurs sites hébergés.

Jusqu'à hier, tout fonctionnait parfaitement. Quatre sites sont hébergés sur ce serveur, deux font appel à PHP-MySQL (un site SPIP, un site maison), deux sont en HTML (+css mais bon ça ne change rien).

Seulement, depuis hier, les sites faisant appel à PHP et Mysql n'affichent plus rien. Quand on pointe sur l'adresse on a une page vide, sans message d'erreur.

La seule différence, c'est qu'hier nous avons essayé d'installer la (...)

Forum Programmation.web réobtenir le code html contenu dans un CDATA

Posté par .
Tags : aucun
0
30
juin
2005
Bonjour,

j'ai dans un fichier xml une balise qui contient du code html. Ce code html est protégé par la balise <![CDATA[

Il y a un fichier xsl qui permet de transformer ce xml en html.
Le problème c'est que dans le fichier html résultant, les balises html contenus dans sont affichées dans le navigateur, en effet les < > sont converti dans le fichier html résultant en entité html : >.

Nous protégeons le HTML car nous considérons ce (...)

Forum Programmation.web masquer https

Posté par .
Tags : aucun
0
28
juin
2005
Salut,

j'ai reussi a configurer mon server apache pour utiliser le protocole https. Mais j'aimerai d'une part que les internautes passent en https sur certaines parties seulement de mon site et d'autre part que le https soit caché (c'est a dire que l'url reste http)...

Voici ce que j'ai rajouté au fichier httpd.conf:


RewriteEngine on
RewriteCond %{SERVER_PORT} ^80$
RewriteCond %{REQUEST_URI} ^.*/admin.*$
(Par exemple, si l'internaute rentre dans http://www.monsite.fr/admin)(...)

RewriteRule ^(.*)$ https://%(...){SERVER_NAME}$1 [R,L]


Le premier problème est donc résolu mais, (...)

Forum Programmation.web des DIV dans un DIV

Posté par .
Tags : aucun
0
27
juin
2005
Bonjour,
j'ai un probleme de CSS, un truc que je ne comprends pas là.
J'ai un div qui englobe d'autres div.
voici mon CSS :

.ligne { border : 1px solid #9370DB;
margin : 1px;
background-color : #FFFAF0; }
.item { float:left;
position:relative;
width:100px; }

et voici mon html : (j'ai mis des [] pour les tags)
[div class='ligne'][div class='item']aaa[/div][div class='item']bbb[/div][/div]

bon, je pensais que le div general allait englober les 2 div à l'interieur, mais pas du tout. le (...)

Forum Programmation.web problème https

Posté par .
Tags : aucun
0
24
juin
2005
Bonjour, j'essaye de tester le protocole https.
Je pense avoir réussi à mettre en place le protocole, mais lorsque je le teste en tapant l'adresse de mon site: https://www.monsite.fr(...) j'obtiens une erreur de proxy (Connecting to mon_ip:443: Connection refused).
Et lorsque je le teste en tapant: http://www.monsite.fr:443(...) ma page s'affiche correctement...
Je ne trouve aucune aide sur internet... S'il quelqu'un pouvait venir à mon aide...

Merci d'avance

Forum Programmation.web Execution d'un binaire depuis page web locale

Posté par (page perso) .
Tags : aucun
0
23
juin
2005
Bonjour !

Je suis en train de realiser un CD qui se presente sous la forme suivante:
*une page web qui s'ouvrira automatiquement sous Windows et qui sert d'ecran d'accueil;
*une application WxWidget qui reside sur le CD.

Sur la page (html) d'accueil, je souhaite mettre des liens vers les divers binaires, en fonction de la plateforme (Win32, OsX, Linux). Le but, c'est qu'un utilisateur lambda ait (sous Win ou OsX) une page d'accueil qui se lance, lui indique ce (...)

Forum Programmation.web POST

Posté par .
Tags : aucun
0
22
juin
2005
Bonjour à tous :)

J'ai implémenté un plugin http pour mon petit serveur, qui gère actuellement GET et HEADER, mais j'aimerais bien ajouter POST afin d'être compatible http 1.0...

Mon problème, c'est que je lis correctement la requête et le body, mais que je ne sais pas quoi faire de ce dernier ^_^'

J'ai examiné la RFC, qui indique différents code de retour suivant que l'on a créé une ressource ou pas. Mais ce que je ne comprend pas, c'est (...)

Forum Programmation.web configuration webdav (suite)

Posté par (page perso) .
Tags : aucun
0
19
juin
2005
Salut, je voudrais pouvoir configurer un serveur webdav sur ma machine et y avoir des droits d'écriture. Mon dav.load ressemble à ça :

LoadModule dav_module /usr/lib/apache2/modules/mod_dav.so

Alias /webdav /var/www

<Location /webdav>
AllowOverride AuthConfig
Options MultiViews Indexes Includes FollowSymLinks
Dav On
AuthType Basic
AuthUserFile /etc/apache2/dav_passwd
AuthName "mon_utilisateur_webdav"
ForceType text/plain
<LimitExcept GET POST PUT DELETE CONNECT LOCK UNLOCK PROPFIND PROPPATCH
MKCOL COPY MOVE HEAD OPTIONS>
# Require valid-user
</LimitExcept>


En sachant que je peux déja y lire, que le propriétaire du dossier (...)

Forum Programmation.web Apache : comment faire pointer toto.domaine.fr vers www.domaine.fr/~user/toto ?

Posté par (page perso) .
Tags : aucun
0
16
juin
2005
Bonjour, je pense que j'ai à peu près tout demandé dans le titre. J'ai bien fait de nombreuses recherches sur des forums, mais je ne suis pas sur de la dénomination exacte (s'agit-t-il d'alias, d'hôtes virtuels ou autre chose)

Si quelqu'un pouvait m'aider ne serait-ce qu'en m'indiquant quoi mettre dans les moteurs de recherche, voire même en me donnant le paramètre à ajouter dans les fichiers conf d'apache2.

Merci

Forum Programmation.web Apache : installer WebDAV pour le https, créer des "alias", etc ..

Posté par (page perso) .
Tags : aucun
0
4
juin
2005
Salut,
pour faire bref, je voudrais installer Webdav sur mon apache2 installé sur une Ubuntu Hoary.
Donc j'ai vérifié que le module était bien présent (il est à l'emplacement /usr/lib/apache2/modules/mod_dav.so). J'ai ensuite (conformément à plusieurs tutoriaux) modifié mon httpd.conf pour y ajouter le LoadModule mod_dav /usr/lib/apache2/modules/mod_dav.so. Quand je fais un restart d'apache2, il plante.
Comme je suis un peu une bouse, je ne sais pas où sont stockés les logs du démarrage du serveur ... ah, si, apparement, ils (...)

Forum Programmation.web récupérer du texte, sans se faire brère

Posté par .
Tags : aucun
0
3
juin
2005
Salut à tous, voilà mon problème :
je veux récupérer du texte ( long plusieurs pages ), à partir d'un site qui génère ses pages en php. Si je fais un coupier coller ça ne marche pas, j'ai regardé les sources de la page, il y a bien mon texte mais il n'est pas totalement en clair ( les accents é et è sont codés ) et la mise en page est perdues, ( avec les illustrations). Quelqu'un a une (...)

Forum Programmation.web limiter le recherches dans mnogosearch

Posté par .
Tags : aucun
0
3
juin
2005
j'utilise mnogosearch pour indexer des fichiers afin de pouvoir faire des recherches a l'intérieur de ces fichiers.
Mnogosearch indexe correctement mes fichiers aussi bien les .doc que les .xsl, .ppt et autres windauberies.
Le problémes vient du fait qu'il m'indexe aussi les repertoires contenant les fichiers
exemple si un fichier s'appelle toto.doc
mnogosearch me renvoi toto.doc ainsi que le répertoire dans lequel il se trouve ce qui fait que l'utilisateur lamba se retrouvera dans un répertoire en cliquant sur le (...)

Forum Programmation.web Quel CMS choisirs ?

Posté par (page perso) .
Tags : aucun
0
2
juin
2005
Bonjour,
je vous demanderais un conseil,
quel cms choisir pour une association ?
Il doit être multilingue (on est en Suisse et on doit gèrer plusieurs langues).
Avoir une galerie de photos (bon c'est secondaire).

L'idéal serait: Les articles sont écrits en français (oui c'est rare en Suisse) quand ils sont publier le traducteur français-Suisseallemand le reçoit dans sa partie a lui et le traduit, idem avec l'italien et l'anglais.

d'habitude je code tous moi même mais la je voudrais (...)

Forum Programmation.web Ligne trop longue

Posté par .
Tags : aucun
0
1
juin
2005
Dans une page j'ai une ligne qui peut potentiellement être trop longue, cette ligne est naturellement indivisible (suite de caractères sans espaces).

Y-a t'il un moyen pour forcer le navigateur à couper cette ligne (ce n'est pas une URL donc les infos peuvent s'étendre sur plusieurs lignes ) plutot que de la faire dépasser ? Je ne trouve rien en CSS pour cela..

Forum Programmation.web validation XHTML

Posté par (page perso) .
Tags : aucun
0
30
mai
2005
Hi,

voilà mon site se base sur du XHTML (parceque la base a été écrite comme ça, moi le HTML me convient :)
et donc, autant le passer au validateur, j'ai ça comme erreur :
Line 79, column 4: document type does not allow element "ul" here; missing one of "object", "ins", "del", "map", "button" start-tag

J'ai été faire un tour sur la specifications XHTML1.0,mais c'estunpeu indigeste et pas grand chose sur les listes.
Quels documents dois-je lire ?
merci,

Forum Programmation.web Toi tu vas à gauche et toi à droite !

Posté par (page perso) .
Tags : aucun
0
25
mai
2005
Bon{jour,soir} !

Une petite question qui va probablement sembler idiote à certains mais je souhaite faire un truc et je n'arrive pas à trouver.


Je code une page en XHTML1.0 Strict + CSS et j'aimerai, sur une seule ligne, avoir du texte à gauche et à droite.

Exemple:

--------------------------- Largeur de la page ---------------------------
| Texte à gauche Texte à droite |


Comment fait-on dans ce cas-là ?

Merci pour vos réponses.

Forum Programmation.web Problème d'encodage

Posté par (page perso) .
Tags : aucun
0
25
mai
2005

Bonjour !

j'ai un souci concernant l'encodage des caractères, enfin, deux :

je mets la ligne <meta http-equiv="Content-Type" content="text/html; charset=utf-8">

au début de ma source HTML enfin PHP enfin on s'en fout enfin bref.

Donc, je mets cette ligne, mais à l'ouverture de la page ouèbe Firefox utilise quand même l'encodage ISO-8859-15….

Plus étrange encore, les é et autres joyeusetés sont interprétées de manière pour le moins étrange… Voila je vous mets l'adresse histoire de pouvoir voir concrètement ce que ca (...)

Forum Programmation.web Faire fonctionner un preg_replace avec les retours chariot ?

Posté par (page perso) .
Tags : aucun
0
23
mai
2005
Hello,
je souhaite utiliser une simple fonction preg_replace pour mettre en gras les parties d'un texte contenues entre des balises prédéfinies (par exemple [B] et [/B]). J'utilise cette fonction :

echo preg_replace('`\[B\](.*)\[\/B\]`', 'strong $1 /strong', $str);

Maintenant, ça fonctionne si les balises [B] et [/B] se trouvent sur la même ligne, mais pas si la balise [B] est sur une ligne et la balise [/B] sur une ligne supérieure (en gros si y a un \n entre la balise [B] (...)

Forum Programmation.web Affichage d'un doc XML avec JSP

Posté par .
Tags : aucun
0
19
mai
2005
Bonjour,
J'ai besoin d'afficher un Doc XML dans une page JSP???

Je voulais savoir est ce que pour afficher un doc XML par une page Jsp j'ai besoin de parser le document et lui associer une feuille de style?????
si c'est non dit moi qu'est ce que je dois faire !!!

Cordailement,

Forum Programmation.web Affichage d'un doc XML avec JSP

Posté par .
Tags : aucun
0
19
mai
2005

Bonjour,

J'ai besoin d'afficher un Doc XML dans une page JSP???

Je voulais savoir est ce que pour afficher un doc XML par une page Jsp j'ai besoin de parser le document et lui associer une feuille de style?????

si c'est non dit moi qu'est ce que je dois faire !!!

Cordailement,

Forum Programmation.web Ajouter dynamiquement des éléments à un formulaire

Posté par .
Tags : aucun
0
18
mai
2005
Salut tout le monde,

Je fais un formulaire html qui a pour but d'uploader des images sur le serveur. http://localhost/~manuel/photo/ajouterchamp.html(...)
En gros je fais un div dans le formulaire et puis j'ajoute les inputs avec ceci:
document.getElementById('monformdiv').innerHTML=
document.getElementById('monformdiv').innerHTML
+"[input type='file' id='photo"+indice+"' name='photo"+indice+"'][br]";
Le problème est qu'à chaque ajout il reset les éléments précédemment ajoutés.

Alors j'ai fait une boucle dans la fonction d'ajout où je recopie les valeurs des inputs dans un tableau avant l'ajout puis je les recopie à (...)

Forum Programmation.web Saut vers une ancre locale en javascript

Posté par .
Tags : aucun
0
17
mai
2005
Hello,

Quelqu'un saurait il comment faire pour défiler le document vers une ancre HTML, via du code javascript ?

L'idée derrière est d'avoir une barre de navigation (générée en DOM) pour faciliter la lecture d'un document (ses changements en fait). Une dlfptoolbar en somme. Sauf que j'ai regardé le code de cette dernière et ça me parait plutôt gore : on calcule la position absolue de l'ancre et on positionne l'attribut document.documentElement.scrollTop à cette valeur :-( (Ça ne marche pas (...)