shingo a écrit 333 commentaires

  • [^] # Re: essayer plusieurs distrib

    Posté par (page perso) . En réponse au message Problème de performance. Évalué à 1 (+0/-0). Dernière modification le 03/11/19 à 15:00.

    J'ai essayé Fedora 31 qui était un peu plus rapide, mais j'ai vite compris que je devais passer par un environnement pas trop gourmand comme XFCE4.

    J'ai remis Debian 10, mais cette fois avec XFCE4 et sa me convient bien pour mon usage.

  • [^] # Re: Debug ACPI

    Posté par (page perso) . En réponse au message Problème de performance. Évalué à 2 (+1/-0).

    J'ai également ces alertes :

    [ 298.417827] perf: interrupt took too long (2513 > 2500), lowering kernel.perf_event_max_sample_rate to 79000
    [ 371.012498] perf: interrupt took too long (3150 > 3141), lowering kernel.perf_event_max_sample_rate to 63000
    [ 400.101928] brcmsmac bcma0:1: brcms_ops_bss_info_changed: qos enabled: false (implement)
    [ 400.101939] brcmsmac bcma0:1: brcms_ops_config: change power-save mode: false (implement)
    [ 471.464781] perf: interrupt took too long (3947 > 3937), lowering kernel.perf_event_max_sample_rate to 50000
    [ 715.107912] brcmsmac bcma0:1: brcms_ops_bss_info_changed: qos enabled: false (implement)
    [ 715.107921] brcmsmac bcma0:1: brcms_ops_config: change power-save mode: false (implement)
    [ 746.163034] perf: interrupt took too long (4935 > 4933), lowering kernel.perf_event_max_sample_rate to 40000

  • [^] # Re: Debug ACPI

    Posté par (page perso) . En réponse au message Problème de performance. Évalué à 1 (+0/-0).

    Non, j'avais utilisé l'ordinateur deux fois puis poser sur une table. Quand le lendemain j'ai voulu l'utiliser et le chargement de Windows était très long. J'ai donc décidé de tout réinstaller le système avec les CD de restauration, sauf que sa prennait également très longtemps et le problème était identique.

    Je n'ai rien pu trouver comme solution, car toutes mes recherches sur le net indique que c'est certainement un problème matériel ou un problème de tension.

    J'ai eu également la batterie HS, je devrais en recevoir une en début de semaine, ce qui me permettra de vérifier si avec uniquement la batterie, j'ai aussi des problèmes d'ACPI.

    J'ai fini par mettre Linux qui fonctionne plus ou moins.

    J'ai regardé dmesg et j'ai pas mal d'erreurs dont :

    [ 23.483594] ACPI Warning: SystemIO range 0x0000000000000428-0x000000000000042F conflicts with OpRegion 0x0000000000000400-0x000000000000047F (\PMIO) (20190703/utaddress-204)
    [ 23.483602] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
    [ 23.483605] ACPI Warning: SystemIO range 0x00000000000011B0-0x00000000000011BF conflicts with OpRegion 0x0000000000001180-0x00000000000011BB (\GPIO) (20190703/utaddress-204)
    [ 23.483608] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
    [ 23.483609] ACPI Warning: SystemIO range 0x0000000000001180-0x00000000000011AF conflicts with OpRegion 0x0000000000001180-0x00000000000011BB (\GPIO) (20190703/utaddress-204)
    [ 23.483613] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver

    Pourrais-tu m'indiquer comment debug l'ACPI ?

    Merci :)

  • [^] # Re: Update BIOS

    Posté par (page perso) . En réponse au message Problème de performance. Évalué à 2 (+1/-0).

    Merci pour vos messages.

    Hier, j'ai installé Fedora 31 qui me semble mieux en terme de performance, mais vraiment légèrement mieux. Etant habitué plus à Debian et ArchLinux, je suis un peu perdu. Je trouve également la gestion des paquets un peu lourde.

    Pour la mise à jour du Bios il n'y en a pas malheureusement, j'avais déjà regardé il y a plusieurs mois et rien.

    Je pense tenter une autre distribution avec un environnement plus light.

    J'étais assez content de Debian, car c'est une distribution que je connais bien. ArchLinux demande trop de travail pour la configuration et je n'a pas le temps ni la patience de passer des heures dans les fichiers conf, surtout que je dois configurer l'environnement afin de pouvoir développer sur d'anciens systèmes (motorolla m68k) et faire tourner différents émulateurs.

  • [^] # Re: Zotero

    Posté par (page perso) . En réponse au message À la recherche d'une solution pour archiver mes publications. Évalué à 1.

    Bonjour, hélas non ce n'est pas ça, car je voudrais que mes articles soit accessibles directement depuis une page type blog ou micro-blog. Mais je prend quand même ce service qui me sera utiliser en temps que sauvegarde :)

    Merci

  • [^] # Re: Réseaux sociaux ?

    Posté par (page perso) . En réponse au message À la recherche d'une solution pour archiver mes publications. Évalué à 1.

    Mastodon ne permet pas de mettre de longs textes et diaspora je crois qu'il est n'est pas possible de travailler un peu sur la mise en page.

  • [^] # Re: Bad idea

    Posté par (page perso) . En réponse au message SSD dans un serveur ?. Évalué à -2.

    Faudrait que tu m'expliques pourquoi tu veux démarrer un serveur rapidement. J'en vois vraiment pas l'intérêt, sauf dans des cas exceptionnels où les services doivent être initialisés le plus rapidement possible.

    J'utilise un vieux HDD 2.5 de 160Go, le système doit prendre environ 2 à 3 minutes pour redémarrer en comptant le temps de démarrage du bios. Démarrer à la vitesse de l'éclair sur un serveur qui aura 1 à 2 reboot dans le mois, à quoi sa sert concrètement dans un cadre privé ?

  • [^] # Re: Debian, dans l'idéal.

    Posté par (page perso) . En réponse au message Quelle distribution choisir ? . Évalué à 1.

    Je pense exactement la même chose, d'ailleurs ça me rappel que lorsque j'ai commencé à utiliser Linux c'était Debian sans la moindre hésitation. A l'époque c'est vrai qu'il n'y avait pas grand choix entre RedHat, Mandriva et Debian, mais même aujourd'hui je foncerais et je fonce toujours sur Debian pour pas mal de raisons.

    D'une part, parce que c'est une distribution stable et bien pensée. Il y a beaucoup de documentations, des tutoriels, infos, etc. Bref, tu ne seras jamais bloqué avec Debian et les mises à jour se feront en douceur.

    Pour les paquets trop vieux, il suffit de passer en testing qui reste quand même stable (bien plus que certaines distributions) et cela te permettra d'avoir des paquets récents.

    Dans mon cas j'utilise Debian 8 (stable) sur mon serveur domestique et mon HTPC. En machine de bureau j'ai plus tendance à pencher vers ArchLinux ou Debian 8 (testing).

    Le problème avec Ubuntu, c'est que c'est une véritable usine à gaz et je n'aime pas trop le fait de vouloir transformer Linux en un système grand public. Il reste Fedora qui est très bon pour un débutant, c'est une distribution vraiment excellente que j'aime beaucoup. En revanche, je ne l'utilise pas personnellement, car je suis trop habitué à travailler avec Debian et Archlinux, du coup pas envie de me taper du yum.

    Il faut que tu saches que choisir sa distribution n'est pas anodin et cela te prendra du temps pour trouver tes marques. Je te conseille vraiment Debian si tu as vraiment envie de basculer pour de bon vers Linux. Se sera plus difficile qu'Ubuntu et Fedora, mais au final tu auras de bonnes bases.

    Il y a ArchLinux qui est très formateur, mais c'est une distribution beaucoup trop contraignante à maintenir. Cela fait plusieurs années que je l'utilise, mais si tu ne fais pas gaffe ou que tu ne mets pas à jour ton système très régulièrement, tu peux te retrouver avec un système down. Cela m'est déjà arrivé, heureusement il est possible de démarrer depuis une clé USB et chrooté le système pour réparer, mais dans le pire des cas il faut tout réinstaller … à la main.

    Non vraiment fonce chez Debian, c'est propre, stable et c'est une bonne base.

  • # Bad idea

    Posté par (page perso) . En réponse au message SSD dans un serveur ?. Évalué à -4.

    Bien que toujours tentant, c'est une très mauvaise idée d'utiliser un SSD pour le système de son serveur et principalement parce qu'il n'y a pas besoin de démarrer rapidement le serveur. Un serveur c'est fait pour rester allumer continuellement et pour les rares fois où tu vas devoir redémarrer la machine ça ne vaut vraiment pas le coup.

    Au niveau de l'écriture des logs, ça ne pose pas vraiment de problèmes à moins que ton serveur gère une tonne de logs détaillés. La durée de vie d'un SSD diminue plus rapidement lorsqu'on s'amuse à écrire plusieurs dizaine de GO par jour.

    Après tu peux toujours utiliser ton SSD et monter /var sur un disque dur classique. Enfin personnellement, j'utilise des SSD uniquement pour les systèmes qui ont besoin de démarrer rapidement comme un HTPC ou une machine de jeux par exemple.

    Sinon, si c'est la mémoire flash qui t'intéresse et que tu veux économiser un emplacement 3.5 ou 2.5, tu peux utiliser une clé USB si tu dispose d'un port adéquat sur la carte mère. Mais à voir si tu peux installer ton OS et démarrer sur la clé.

  • # Ouf

    Posté par (page perso) . En réponse au message [resolu] LVM : perte des partitions après changement du hostname. Évalué à 4.

    Ouf finalement c'était mdadm qui avait besoin d'une petite mise à jour :

    mdadm --assemble /dev/md0 /dev/sdc1 /dev/sdd1 --update=name

    :)

  • [^] # Re: mon humble avis

    Posté par (page perso) . En réponse au message mdadm vs lvm. Évalué à 1. Dernière modification le 20/10/16 à 11:49.

    Merci pour ton conseil et tes explications. C'est vrai que c'est mieux de se contenter d'un raid 1 et d'acheter un troisième HDD pour passer sur un raid 5. Je ne sais pas pourquoi j'y ai pas pensé plus tôt !

    Donc RAID1 + partitions LVM + quotas.

  • [^] # Re: pas possible, et c'est logique/normal

    Posté par (page perso) . En réponse au message mdadm : booter grub sur raid 0. Évalué à 1.

    Oui voilà ^ Dommage que je n'ai pas la possibilité d'installer en plus un SSD, j'aurais pu mettre directement le système dessus sans me prendre la tête.

  • [^] # Re: pas possible, et c'est logique/normal

    Posté par (page perso) . En réponse au message mdadm : booter grub sur raid 0. Évalué à 1.

    Compris ! C'est bien dommage, mais logique. J'ai donc utilisé une partition de 512m pour le boot et une partition de 512m sur l'autre disque pour le swap :) Ça boot comme par magie :)

  • [^] # Re: btrfs

    Posté par (page perso) . En réponse au message Fusionner deux disques ou deux partitions. Évalué à 1.

    Ah merci c'est très clair maintenant :)

  • [^] # Re: btrfs

    Posté par (page perso) . En réponse au message Fusionner deux disques ou deux partitions. Évalué à 1.

    Une petite question concernant le mdadm, je suis obligé de créer en premier les partitions que je souhaite faire tourner en raid 0 ou est-ce qu'il est possible faire un raid 0 avec les deux disques durs et créer par la suite plusieurs partitions ?

    Je viens de créer un raid 0 en utilisant les deux disques, mais du coup impossible de créer des partitions. Pour que le raid 0 soit optimale avec les partitions, elles doivent égales ?

  • [^] # Re: btrfs

    Posté par (page perso) . En réponse au message Fusionner deux disques ou deux partitions. Évalué à 1.

    Pour la panne j'ai oublié de préciser que je vais sauvegarder régulièrement les données sensibles sur un disque dur externes (photos, documents, …). Après si je perds des films ou séries tv, etc. parce qu'un disque dur à lâché, ce n'est pas grave. De toute façon rien n'est sûr à 100% à moins de faire des backups réguliers.

  • [^] # Re: Essais de changer le backend utilisé par plasma

    Posté par (page perso) . En réponse au message Problème d'affichage avec Plasma 5 . Évalué à 1.

    J'ai essayé toutes les possibilités, OpenGL 2 et 3, mais aussi XRender, c'est pareil. Avec XRender, c'est pire, tout l'écran est recouvert de carré de pixels, alors qu'avec OpenGL 2 ou 3, je peux au moins voir la barre des tâches et lancer des applications. Je suppose que le problème provient des pilotes AMD "trop anciens" et de l'ancienne version de Xorg.

  • [^] # Re: Accélération graphique ?

    Posté par (page perso) . En réponse au message Problème d'affichage avec Plasma 5 . Évalué à 1.

    J'ai bien supprimé le dossier .kde4 mais c'est pareil, l'écran clignote dans tous les sens au démarrage.

  • [^] # Re: .local

    Posté par (page perso) . En réponse au message Problème d'affichage avec Plasma 5 . Évalué à 1.

    J'ai bien supprimé ces deux dossiers, mais le résultat est le même. J'ai toujours le fond d'écran avec des gros pixels et parfois il s'affiche convenablement mais seulement pour quelques secondes.

  • [^] # Re: Montage

    Posté par (page perso) . En réponse au message KDE : samba & stream, c'est possible ?. Évalué à 3.

    Merci pour ton éclaircissement, je vais monter ça avec cifs dans mon fstab, merci encore :)

  • # Abusé !

    Posté par (page perso) . En réponse au journal L'autohébergement, c'est pas gagné. Évalué à 2.

    Je trouve cela abusé et vraiment frustant, surtout si tu ne peux pas rectifier le tir. Le problème avec l'autohébergement, c'est que les acteurs ne jouent pas le jeu et très peu de personnes tentent de faire bouger les choses. J'ai eu le même souci avec mon FAI, mis à part qu'après avoir fait une demande auprès du responçable de la liste noire, j'ai pu de nouveau envoyer des mails après une ou deux heures. J'ai arrêté l'autohébergement, car ma connexion ADSL est trop instable et le débit montant inssufisant pour mes besoins. Alors bien sûr, faire de l'autohébergement pour ses mails, ça n'a rien de bien compliquer et ne demande pas trop de ressources, mais j'avoue que quand on rentre pour la première fois dans les fichiers de configurations de postfix et dovecot, il y a de quoi s'arracher les cheveux d'autant plus que coulé à postfixadmin, il faut créer ses propres requêtes sql. A chaque fois que je dois reconfigurer un serveur de mail, ça me prend plusieurs heures avant de capter mes erreurs.

    Enfin cela dit, j'aurais adoré vivre pleinement l'autohébergement, mais tant que j'aurais de l'ADSL c'est pas la peine d'y penser. En ce moment je travail sur une application type Facebook, et ne serait-ce que pour les albums photos des membres, ma bande passante serait exploser.

    Dans ton cas je pense que la meilleure solution c'est d'avoir son propre vps.

  • [^] # Re: Finallement...

    Posté par (page perso) . En réponse au message Une table group pour gérer les droits utilisateurs ?. Évalué à 1.

    Oui c'est clair, d'autant plus que le système proposer permet pas mal de souplesse dans l'affectation des droits. Bon par contre, c'est très complexe à utiliser et un peu lourd à mon goût, mais je suppose qu'il n'y a pas de meilleures solutions que les fameux ACLs. Au départ j'étais parti pour mélanger l'authentification et les acls afin de définir les droits pour chaque action, mais ça devient vite le bordel alors que j'en ai pas spécialement besoin. Je suis donc parti sur un auth classique couplé aux ACLs. :)

  • # Finallement...

    Posté par (page perso) . En réponse au message Une table group pour gérer les droits utilisateurs ?. Évalué à 1.

    Je m'étais pas aperçu que le framework que j'utilise propose tout un système de droits pour chaque objet, donc autant l'utiliser :)

  • [^] # Re: Ca dépend...

    Posté par (page perso) . En réponse au message Une table group pour gérer les droits utilisateurs ?. Évalué à 1.

    Pour le moment j'ai juste besoin de quelque chose de basique. Au départ, j'utilisais juste un champ role dans la table user pour définir les droits des utilisateurs, mais ça a ses limites. Actuellement j'ai une table user_groups avec plusieurs champs qui me permettent de terminer les droits.

    J'ai quatre groupes : administrator, super_moderator, moderator et member. Donc si un groupe possède la valeur edit_post à true, l'utilisateur pourra modifier un message sur le forum etc.

    Au niveau des droits, je ne pense pas faire quelque chose de complexe, car c'est un site communautaire ou chaque membre possède un profil, des albums photos, etc. J'ai juste besoin de séparer certaines actions entre les différents types de modérateurs et les membres.

  • [^] # Re: logique à 2 niveaux

    Posté par (page perso) . En réponse au message Question sur le nommage des tables. Évalué à 1.

    Je viens d'avoir juste à l'instant le même raisonnement. Il faudrait qu'une entreprise soit un "user" et je rajoute comme tu le dis, un champ qui me permet de savoir si c un pro ou un particulier.

    Du coup, ça va me simplifier la vie ! Merci beaucoup c'est la solution ultime !!!!